Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm still exploring server administration and networking (I'm an intern) and I've set up an FTP server at our company and set up a user account for all the workers here. Problem is I can connect one person every 15 minutes.

I connect one user then disconnect that user. Then if I try to reconnect(even using the same user), it will connect until it accepts to login, then it times out. I use FileZilla and this is what I get when connecting:

Status: Connecting to **********...
Status: Connection established, waiting for welcome message...
Response:   220 Welcome to ******* FTP service.
Command:    USER *******
Response:   331 Please specify the password.
Command:    PASS *******
Error:  Connection timed out
Error:  Could not connect to server

I use vsftpd and here is the config file:

# Example config file /etc/vsftpd/vsftpd.conf
#
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=NO
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# The target log file can be vsftpd_log_file or xferlog_file.
# This depends on setting xferlog_std_format parameter
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# The name of log file when xferlog_enable=YES and xferlog_std_format=YES
# WARNING - changing this filename affects /etc/logrotate.d/vsftpd.log
#xferlog_file=/var/log/xferlog
#
# Switches between logging into vsftpd_log_file and xferlog_file files.
# NO writes to vsftpd_log_file, YES to xferlog_file
xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that on some FTP servers, ASCII support allows a denial of service
# attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
# predicted this attack and has always been safe, reporting the size of the
# raw file.
# ASCII mangling is a horrible feature of the protocol.
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
ftpd_banner=Welcome to ********** FTP service.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd/banned_emails
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
#chroot_list_enable=YES
# (default follows)
#chroot_list_file=/etc/vsftpd/chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES
#
# When "listen" directive is enabled, vsftpd runs in standalone mode and 
# listens on IPv4 sockets. This directive cannot be used in conjunction 
# with the listen_ipv6 directive.
listen=YES
#
# This directive enables listening on IPv6 sockets. To listen on IPv4 and IPv6
# sockets, you must run two copies of vsftpd whith two configuration files.
# Make sure, that one of the listen options is commented !!
#listen_ipv6=YES

pam_service_name=vsftpd
userlist_enable=YES
tcp_wrappers=YES
share|improve this question
    
Need more details... What FTP server service are you running (Filezilla as well?), whats your config filelook like... –  RomeNYRR Feb 22 '12 at 14:17
    
VSFTPD and config is in post –  Native Feb 22 '12 at 14:24
    
You're vsftp.conf looks good. Were the timeout settings already commented out? If not have you restarted the VSFTPD service since the change? Can you reproduce the same behavior using a different FTP client? When you get the Connection timed out error can you run "telnet FTPHOST 21"; does it timeout as well? I'm going to assume you have IPTables running, have you added a rule to your chain to allow for FTP access? –  RomeNYRR Feb 22 '12 at 14:50
    
I didn't edit the timeout settings so those are the defaults. I've restarted the VSFTPD service and restarted server several times. I'll check for another FTP client. telneting works with a user, but it seems to take about a minute to login. yes, I have port 21 open in iptables. –  Native Feb 22 '12 at 15:05
    
I think I may have found the reason. It simply seems to take a very long time to connect. I increased the timeout time in filezilla from 20 seconds to 60 and it now seems to connect. Now I just have to find out why it's taking so long to connect. –  Native Feb 22 '12 at 15:27

1 Answer 1

Glad it's working (somewhat) Are you connecting via Hostname or IP? Is the connection time the same for both? If it's different for hostname, could be a DNS issue. Also try using the regular FTP command line utility and see if you're getting the same behavior. Could just be something funky with Filezilla

share|improve this answer
    
Connecting via IP, I've yet to set yup a hostname. Thanks for the help. –  Native Feb 22 '12 at 19:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.