Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I browse to localhost/ and nothing is shown. No web page, no 'page not found' etc.

However, I change httpd.conf to use port 8080, then browse to localhost:8080/ and my local pages show up.

Why would this happen? Is something else using port 80? What software would do this? How can I find out if other software is using these ports?

I am using Windows XP SP3, I have installed Apache on a user's desktop so that they can do their web development.

There is no IIS on this machine. Only 1 entry in the hosts file (127.0.0.1 localhost) and I have uninstalled skype, which uses port 80 apparently).


SOLVED

Thanks for all your answers, eventually I deleted all the rubbish out of my HTTPD.conf files, got back to a working state then rewrote the rules.

I have a feeling that I didn't have the first line here:

NameVirtualHost 127.0.0.1

<VirtualHost 127.0.0.1>
    ServerName localhost
    DocumentRoot "C:\webroot"
</VirtualHost>
share|improve this question
    
What platform are you on? –  Sven Jul 6 '09 at 10:52
    
Updated my question, thanks sweimann. –  Jon Jul 6 '09 at 11:00

4 Answers 4

up vote 1 down vote accepted

I'm not exactly sure what you're describing, but some steps that I would take to trouble shoot this would be:

  1. Verify that Apache is starting without errors by checking the Apache log
  2. Check that Apache is listening on port 80 with netstat -bn (use the n flag so you can see the port number rather than a description)
  3. Verify that it's definitely not a firewall by turning it off briefly and seeing if that solves the problem
  4. keep an eye on the Apache access logs and error logs while you attempt to access the server to see whether or not you get as far as talking to Apache at all.

Hopefully one of these steps will point you in the right direction.

share|improve this answer

Yahoo Messenger file transfer also uses port 80 by default.
Also you can use netstat -b to display the executable involved in creating each connection or listening port.

share|improve this answer

Do you have windows firewall on? Apache won't create an exception whenever you change the port by itself. You can check what ports are being listened on with netstat -a

share|improve this answer

You need to set your Listening port to 80.

You (probably) need admin privileges to do that.

http://httpd.apache.org/docs/1.3/mod/core.html#listen

jrh

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.