Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recieve the following error when I try to configure SharePoint 2010 Server:

"Cannot connect to the database master at SQL server at [computer.domain]. The database might not exist, or the current user does not have permission to connect to it."

I run the following setup:

  • Windows Server 2008 R2 Standard with SP1 and all the updates
  • SQL Server 2008 R2 with SP1
  • SharePoint Server 2010 with SP1
  • Everything is installed on the same server (it's a testserver)

I have tried the following:

  • Rebooting the server
  • Checking the install account's DB rights (dbcreator, securityadmin - I even let it have sysadmin)
  • Opened up the firewall on port 1433 and 1434
  • Uninstalled both SQL and SP, then reinstalled the both
  • Enabled all client protocols in SQL Server Configuration
  • Made sure I used the correct account for installing SharePoint (local admin)

Useful links: TCP/IP settings –> http:// blog.vanmeeuwen-online.nl/2010/10/cannot-connect-to-database-master-at.html

http:// ybbest.wordpress.com/2011/04/22/cannot-connect-to-database-master-at-sql-server-at-sql2008r2/

Wrong slash -> http:// yakimadev.com/2010/11/cannot-connect-to-database-master-at-sql-server-at-serverdbname-error-during-sharepoint-2010-products-configuration-wizard-and-installation/

Port error -> http:// www.knowsharepoint.com/2011/08/error-connecting-to-database-server.html

share|improve this question

migrated from stackoverflow.com Feb 23 '12 at 2:10

This question came from our site for professional and enthusiast programmers.

    
Hello! Did you ever find a solution? –  BGM Nov 16 '12 at 1:03

1 Answer 1

I know this is an old question, but, check the binding for your portal site in IIS. Click the "edit" button and make sure a certificate is chosen for your ssl binding. If there is no certificate (or it "came loose" somehow), you won't be able to access the site at all.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.