Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We've got a few internal applications (such as RAID, UPS, Firewall, etc) that want to send monitoring mails. We have a Exchange 2010 on the SBS 2011 server, Outlook and ActiveSync and such business email related stuff work fine. However, I have been unable to make any of them send mail through Exchange. They all offer settings for smtp, so I figured it should be pretty simple. But alas, no.

None of the applications feature an informative error about why sending of mail failed, so I get no help there. I have tried adding verbose logging to the send connector in exchange, but I don't get any events in that log at all.

So: Are there any settings that need to be specified for letting applications send mail using exchange as smtp server? And how can I debug this when the send connector does not see anything?

share|improve this question
1  
do you want to send to a domain which is configured on this server or to an external domain? –  Raffael Luthiger Feb 23 '12 at 20:59
    
Only internal domain, I just want an email alert to a distribution list –  carlpett Feb 23 '12 at 21:25

2 Answers 2

up vote 4 down vote accepted

You need to configure the default receive connector on your Exchange server to accept connections from those devices, and to allow anonymous connections if they are unable to use authenticated SMTP. Both of these settings are in the default receive connector's properties.

You can also create a custom receive connector to be used by internal devices, if you don't want to change the default one's settings; but you'll need to have it listen on a different IP address or a custom port, because port 25 on the Exchange server's main IP address is already in use by the default receive connector.

The send connector is completely unrelated; it's used to send messages to external recipients, but first you need those messages to get into Exchange, and that goes through a receive connector.

share|improve this answer
    
Thanks, that makes a lot of sense! Just wondering about the port change (since the RAID manager didn't like changing the port); there were three recieve connections on my exchange installation, Default, Windows SBS Sharepoint Fax and Windows SBS Internet Receive. All of these were configured to use port 25? –  carlpett Feb 23 '12 at 21:28
    
Either they are using different ports, or different IP addresses. Only one connector (only one process in the whole system, actually) can use a given address/port pair. –  Massimo Feb 23 '12 at 21:55

What you probably want to do is Allow Anonymous Relay on a Receive Connector. If you want to send to an external domain.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.