Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Ubuntu 11.10 x64 guest running under Hyper-V on Windows Server 2008 R2 SP1, configured according to these directions, including installation of the hyper-v modules. Network speed is fine (500 MB/s, measured with iperf), but disk access is laughable (3 MB/s, measured with dd).

What could possibly be causing this issue?

My other Ubuntu VMs have the same problem, my Windows VMs do not have this problem.

share|improve this question
    
thanks for fixing my spelling @Jacob :) I've been spelling it "uBuntu" for years, but google tells me I'm pretty much alone in that. I wonder where I picked that up? –  Boinst Feb 24 '12 at 2:36
    
Out of curiosity, do you have the same issue with CentOS 6 after you install the integration tools? –  Will Feb 27 '12 at 3:36
    
I have not tried CentOS. I've only tried Ubuntu and Windows 7. I do need to run Ubuntu ultimately because it's part of a continuous integration process that needs to pass its unit tests and build ubuntu binaries for shipping. If installing a CentOS VM would help for diagnostic purposes I can do that, but I can't imagine how it would. My current best option is to convert the server to an ESXi host. –  Boinst Feb 28 '12 at 2:56
    
Are you using IDE or SCSI controllers for your virtual disks? –  Bigbio2002 Feb 28 '12 at 4:11
    
@Bigbio2002, the default: IDE. I'll switch it and see if it makes a difference. –  Boinst Feb 28 '12 at 4:37
show 7 more comments

2 Answers

I'm not sure if this has been fixed, but at one point you had to enable the Hyper-V modules in Ubuntu 10.04/2.6.x kernel (/etc/initramfs-tools/modules):

hv_vmbus

hv_storvsc

hv_blkvsc

hv_netvsc

share|improve this answer
    
Did that. Edited /etc/initramfs-tools/modules, did update-initramfs -u, rebooted, and confirmed modules were running with the command lsmod | grep hv_. Good suggestion though, that could be the cause for others with the same problem, thank you. –  Boinst Feb 27 '12 at 2:38
    
@Boinst did it fix the problem in any way? –  Nils Feb 28 '12 at 20:29
    
@Nils, I followed these steps before posting my question. I will update the OP to note this fact. –  Boinst Feb 29 '12 at 0:12
add comment
up vote 0 down vote accepted

Unfortunately, Hyper-V is just not that great for virtualising linux. Use VMWare Converter to convert the server to an ESXi image, install ESXi on the server, then run the Windows machine as a VM. You can run the Ubuntu VMs as ESXi images with much better performance than you can get under Hyper-V.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.