Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I set up MySQL master-master replication on my 2 Ubuntu VM. Configuration and connection done correctly according to this guide. Here is my problem.

  1. I print the master status on master 1 and it gives position XXX, then I jump to Master 2 and print slave status it is also prints its position as XXX.
  2. I change any configuration beside the must-replicated db position changes. (As usual)
  3. Problem is this when I insert any record to must-replicated db position does not change. Also record does not replicated to Master 2 must-replicated DB.

In logs also it does not give any info about replication.

Here is my 1st master-slave configuration in my.conf files:


log-bin = /var/log/mysql/mysql-bin.log


share|improve this question
check on master 1 and master 2 the Slave_IO_Running & Slave_SQL_Running via slave status, make sure it's YES. if one of them is NO, check your setup again. – chocripple Feb 24 '12 at 9:19
these are both yes – barisinanc Feb 24 '12 at 9:44
have you try to recreate the db ?, is it sync ? if yes, try to insert records. – chocripple Feb 24 '12 at 10:08
they are sync, when i insert records database just do nothing for replication. I cannot see any action on logs or database. – barisinanc Feb 24 '12 at 13:51
remove replicate-do-db and have you try using another option like replicate-wild-do-table=db_name.% and replicate-ignore-db ? – chocripple Feb 26 '12 at 3:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.