Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I can't install any php extension

Epel repository enabled

Yum is updated

yum repolist shows

repo id                                repo name                                                                      status
base                                   CentOS-6 - Base                                                                  5,932+362
epel                                   Extra Packages for Enterprise Linux 6 - x86_64                                 5,867+1,143
extras                                 CentOS-6 - Extras                                                                        4
updates                                CentOS-6 - Updates                                                                  334+83
repolist: 12,137

yum install php-soap or yum --enablerepo=epel install php-soap output:

    Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirrors.dedipower.com
 * epel: mirror01.th.ifl.net
 * extras: mirrors.dedipower.com
 * updates: mirror.as29550.net
Setting up Install Process
No package php-soap available.
Error: Nothing to do

epel.repo content

[epel]
name=Extra Packages for Enterprise Linux 6 - $basearch
#baseurl=http://download.fedoraproject.org/pub/epel/6/$basearch
mirrorlist=http://mirrors.fedoraproject.org/metalink?repo=epel-6&arch=$basearch
failovermethod=priority
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6

[epel-debuginfo]
name=Extra Packages for Enterprise Linux 6 - $basearch - Debug
#baseurl=http://download.fedoraproject.org/pub/epel/6/$basearch/debug
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-debug-6&arch=$basearch
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
gpgcheck=1

[epel-source]
name=Extra Packages for Enterprise Linux 6 - $basearch - Source
#baseurl=http://download.fedoraproject.org/pub/epel/6/SRPMS
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-source-6&arch=$basearch
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
gpgcheck=1

UPD

yum search php :

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
epel/metalink                                                                                             |  13 kB     00:00
 * base: mirrors.dedipower.com
 * epel: mirror01.th.ifl.net
 * extras: mirrors.dedipower.com
 * updates: mirror.as29550.net
======================================================= N/S Matched: php ========================================================
cups-php.x86_64 : Common Unix Printing System - php module
eclipse-phpeclipse.noarch : PHP Eclipse plugin
graphviz-php.x86_64 : PHP extension for graphviz
nntpgrab-php.x86_64 : PHP module which allows PHP scripts to communicate with NNTPGrab
rrdtool-php.x86_64 : PHP RRDtool bindings
uuid-php.x86_64 : PHP support for Universally Unique Identifier library
lighttpd-fastcgi.x86_64 : FastCGI module and spawning helper for lighttpd and PHP configuration
limph.noarch : A PHP5-compatible network host/service poller with web interface
tiquit.noarch : A PHP5-compatible help desk incident tracking/knowledgebase system

  Name and summary matches only, use "search all" for everything.

UPD2 Solved. Thanks all. Problem was explude = php.* in my yum.conf

share|improve this question
    
Are you behind the proxy, and please paste error also –  neolix Feb 24 '12 at 9:45
    
can you do a yum search php and see if the soap (or any other rpm for that matter) exists? –  qweet Feb 24 '12 at 9:52
    
no, i am not behind the proxy –  sbxmal Feb 24 '12 at 10:00
    
can attache error when you run yum install XXX -y –  neolix Feb 24 '12 at 10:06
6  
Please don't add your answer to the question or "[Solved]" to the title. I know it's suggested but it's not how Stack Exchange really works. Add your solution as an answer when you can. –  ChrisF Feb 24 '12 at 10:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.