Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Maybe this is a silly question but since I'm not a sysadmin I could not find a solution for this problem:

I made a clean installation of CentOS 6.2 (64bits) and I didn't change any configuration after that, I started Apache (as root) with

/etc/init.d/httpd start

If I navigate to localhost I get a correct response from my server but if I try to navigate through my network IP (172.16.8.59) I get an error:

(113) No route to host

I google the error and everything points to the squid configuration as far as I read but not sure because I don't even have the squid service installed.

Thanks in advance!

share|improve this question

1 Answer 1

up vote 1 down vote accepted

If you have the default firewall rules enabled you will not be able to access Apache without some additional configuration. The simplest solution is to run the system-config-firewall tool and check the 'WWW (HTTP)` checkbox.

You can also disable the firewall temporarily by running:

service iptables stop

And you can disable the firewall permanently by follow the previous command with:

chkconfig iptables off
share|improve this answer
    
Thank you! That was exactly the problem..! Solved –  Gilberto Ramos Feb 24 '12 at 18:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.