Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have the following in my httpd.conf

<VirtualHost *:80>
    ServerName foo.org
    ServerAlias www.foo.org

    <Proxy *>
        Options FollowSymLinks MultiViews
        Order allow,deny
        Allow from all
        AllowOverride All
    </Proxy>

    ProxyPass        / http://127.0.0.1:5012/
    ProxyPassReverse / http://127.0.0.1:5012/
</VirtualHost>

This works well as all requests for http://foo.org get served from port 5012 using a different web server. However, I want to serve just http://foo.org/lib via Apache from port 80. How do I do that? Adding the following lines to the conf doesn't help

Alias /lib /path/to/lib

<Directory "/path/to/lib">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
</Directory>
share|improve this question

1 Answer 1

up vote 2 down vote accepted

You can avoid proxying for a specific location by telling mod_proxy to ignore it with a ! for a destination:

ProxyPass        /lib !
ProxyPass        / http://127.0.0.1:5012/
ProxyPassReverse / http://127.0.0.1:5012/
share|improve this answer
    
awesome! it was that easy! I tried NoProxy and ProxyMatch with various regexps to no avail. Thanks. –  punkish Feb 26 '12 at 0:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.