Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Frustratingly when I was setting email up I was sending test emails to my googlemail account. Now our IP has been blacklisted, all gmail emails end up in badmail with this notice:

Final-Recipient: rfc822;xyz@gmail.com
Action: failed
Status: 5.5.0
Diagnostic-Code: smtp;550-5.7.1 [108.60.144.10       1] Our system has detected an unusual rate of
550-5.7.1 unsolicited mail originating from your IP address. To protect our
550-5.7.1 users from spam, mail sent from your IP address has been blocked.
550-5.7.1 Please visit http://www.google.com/mail/help/bulk_mail.html to review
550 5.7.1 our Bulk Email Senders Guidelines. j20si5947381qct.182

We have spare IP's so I though I'd just change the IP of the SMTP server from 108.60.144.10 to 108.60.144.14:

enter image description here

However when we send emails to gmail they still come back with the same error message and originating IP address.

What do I need to do to change this?

share|improve this question
    
Just a thought, but you may want to obscure your IP addresses. Disclaimer: I'm paranoid. –  Wesley Feb 27 '12 at 4:21
add comment

1 Answer

The option to change the IP address is for inbound connections. Outbound connections are not, to my knowledge, configurable within IIS when multiple IP addresses exist on a network card. The IIS SMTP service grabs the default IP address on your network card and uses that as the outbound SMTP virtual server.

The solution is to change the default IP address on your NIC. The "default" is the first IP address that shows up when you look at TCP/IP v4 properties. So-called "non-default" IPs are those that are seen when you click the Advanced... button and then view the IP Settings tab.

Swap the default IP for one of the ones on the IP Settings tab.

share|improve this answer
    
It's still sending from 108.60.144.10 when I look in the email header, here's some screenshots of our setup: imgur.com/WV7Kr –  Tom Gullen Feb 27 '12 at 17:54
    
@TomGullen You will likely have to restart IIS. –  Wesley Feb 27 '12 at 20:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.