Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to syncronize two NAS remotely located. They run FreeNAS 8.0.3 and I've been using rsync to syncronize data over the Internet. The sync literally copies NAS1 to NAS2. Unfortunately, the internet pipe is not big enough and I'm now about 100Gb off sync.

I wrote a script on NAS1 that using --dry-run writes the list of files to sync. I now would like to use this list to copy data from NAS1 into a USB hard disk drive that can be carried over manually and plugged into NAS2.

I haven't tested it yet, but in theory it works. I'm just concerned that file attributes will not be maintained when copying from NAS1 to USB and from USB to NAS2. Thus, when running my overnight rsync-over-the-internet it will find the files, but with different attributes and decides to overwrite them.

Is there any way to work around this attributes problem? Disabling the attributes checks is not an option.

share|improve this question
add comment

2 Answers 2

up vote 3 down vote accepted

As SvenW says, format the USB drive in the native filesystem for FreeNAS, and you should be fine.

Alternatively, tar up the files from NAS1 to the hard drive. That should insulate the attributes regardless of the the filesystem of the hard drive.

I think attribute changes will not cause rsync to transfer the file again, anyway. rsync should just be changing the attributes in that case.

share|improve this answer
add comment

I don't know FreeNAS, but if you can connect an USB disk with an ext3/4 filesystem (or whatever is native to it), the attributes should be transferred correctly. \

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.