Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have an EC2 base instance, and they usually have password authentication disable in the sshd service. They only authenticate with key. The situation I have is every time I try to ssh into another linux host that authenticate with password I get the following message:

Warning: Permanently added 'customerstg.domain.net' (RSA) to the list of known hosts. Permission denied (publickey,gssapi-with-mic,password).

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Ok. Sorry to bother everyone. I found the issue of my situation. In my EC2 server, under the /root/.ssh/ directory is a file called config.

This file had the following settings:

StrictHostKeyChecking no
CheckHostIP no

PasswordAuthentication no

I change the PasswordAuthentication from no to yes.

And that fixed the situation. I hope this helps other people.

share|improve this answer

What are the permissions on the remote host's user's .ssh directory? IIRC, they must be 700 to work properly. If you're coming from a Linux host, then permissions on the local id_rsa/dsa file(private key) must be 600.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.