Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using rsync to sync a directory to a USB-mounted device. That device automounts with myuser:root ownership. When I rsync my directory (that has myuser:myuser ownership) with -a, I get many of the following errors:

rsync: chgrp "filename" failed: Operation not permitted (1)

I tried adding --no-g after the -a option (since in this case I don't care about setting the group), but the errors persist. What do I need to do to stop rsync from trying to chgrp everything?

share|improve this question
    
What filesystem is on the device? –  Andrew Feb 28 '12 at 2:22
    
@Andrew: It's vfat. –  jrdioko Feb 28 '12 at 2:53

1 Answer 1

up vote 3 down vote accepted

FAT does not have permissions; you could try either re-mounting the device with different owner/group/umask, or expanding the archive flag and removing

  • "preserve permissions" flag -p
  • "preserve groups" flag -g
  • "preserve symlinks" flag -l
  • "preserve special & device files" flag -D

Essentially rsync -rt is good enough for a FAT target.

The lazy option would be sudo rsync -a $target $dest 2> /dev/null (run as root to try and force the group change, ignore error messages).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.