Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have just successfully created a meeting room with option Enable the Resource Booking Attendant in Exchange 2010. However, the Domain Users are not able to book the room. My understanding the option Enable the Resource Booking Attendant will make the room public.

In Exchange Managemenet Shell, I try to grant a user Access Right to this meeting room as Author:

Add-MailboxFolderPermission -Identity testroom:\Calendar -User "user@domain.com" -AccessRights Author

Soon after the press enter on the above command, the user can book the room.

I have tried to create either Security Group or Distribution Group to apply the permissions. None of them are working to grant permissions. Ihave got this Error Message:

The User "GroupName" was found in Active Directory but isn't valid to use for permissions. Try an SMTP address instead.

I try to use the SMTP Address, and I got the following Error:

The user "Group SMTP Address" is either not valid SMTP Address, or there is no matching information.

The group SMTP address is exist and fully working.

What are the best practises to grant Author permission to all Domain Users? For sure, I cannot do this to hundreds of users in the office.

Thank you in advance for your help.

share|improve this question
add comment

4 Answers

up vote 2 down vote accepted

I do sincerely aplogise for not posting the answer of my problem.

It was actually my own mistake. I read the documentation on how to Add-MailboxFolderPermission in the wrong way.

The command I use to set this up as followed:

Add-MailboxFolderPermission -Identity testroom:\Calendar -User "default" -AccessRights Author

-User "default" will add all users in Exchange to have Author AccessRights to the testroom resource mailbox.

Hope this is going to help everyone out there set and configure the resource mailbox.

share|improve this answer
add comment

As a newbie to Exchange, I found that before being able to assign permissions to a security group, you have to do 2 things:

  1. Make the security group Universal

  2. mail-enable the security group, i.e. Enable-DistributionGroup -Identity "DEMO-OfficeTest4-RW"

I was then able to run the following:

Add-MailboxFolderPermission -Identity "DEMO-OfficeTest4:\Inbox" -User "DEMO-OfficeTest4-RW" -AccessRights "Owner"
share|improve this answer
add comment

If the group is mail-enabled, it sounds like it may not have been "fully" enabled. I remember reports in Exchange 2007 of existing groups that were mail enabled that did not properly have an attribute set.

Running Set-DistributionGroup should take care of the problem. You shouldn't need to change any settings, just run the command on the group in question, as follows:

Set-DistributionGroup -Identity [groupname]

You may receive an error stating that you need to set to group to "MemberDepartRestriction Closed" - this is because security groups cannot allow members to remove themselves from the group. If you get that error, run this command:

Set-DistributionGroup -Identity [groupname] -MemberDepartRestriction Closed
share|improve this answer
    
Hi Phil, thank you so much for your response. I meant to post the answer of my problem a while ago. However, it is also good to know that in Exchange you can do Set-DistributionGroup. –  Arief Mar 6 '12 at 22:09
add comment

One of the things to check is that the Distribution Group is actually an upgrade to your current Exchange Version. Many groups aren't converted automatically during an Exchange upgrade.

If you try to do

Set-DistributionGroup -Identity [groupname]

on an old distribution group, you will get prompted to upgrade the group to the current Exchange version. Once you do this, you will be able to use the Add-MailboxFolderPermission command to successfully grant the access you want.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.