Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can't seem to find the answer anywhere. So far I've figured out that I need to add (uncomment)

Include = /etc/pacman.d/mirrorlist

On "/etc/pacman.conf" and then run:

sudo pacman-key --init

When I run:

sudo pacman -S

I get:

warning: database file for 'multilib' does not exist

How can I fix this?

share|improve this question
up vote 5 down vote accepted

Refresh the package list first after adding repos: pacman -Syy

Regarding pacman-key --init: you can set up pacman for the use with signed packages. By default pacman will accept unsigned packages. So this step is optional and also requires further steps. Refer to the arch wiki for the whole process:

share|improve this answer
OK, that solved the warning... How do I actually install the 32bit lib? – Boaz Feb 29 '12 at 14:48
As you install every other package pacman -S package_name – duenni Feb 29 '12 at 14:52

You can search for packages named lib32 with: pacman -Ss lib32

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.