Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We run 22 XA6 off of one image through a provisioning server. We also run another 5 doing the same thing (but these 5 do not publish desktops). Now on the 22 servers we have, we will come in on any random morning and find that the Citrix user profiles are gone and that the Citrix profile manager policy has not applied to any 22 of these servers.

We opened up a support ticket because this is the second time it's happened in a little over a week. Here's what we found.

  1. If we went back to an earlier version of the image and booted, viola, profiles there. Mind you the only changes were removing 2 or 3 local printer drivers.

  2. If we did step 1 and then tried rebooting to the most recent image again, still didn't work.

  3. We isolated the test server having this issue with the most recent image applied to it, and put it into our No policies container in Group Policy editor. We added our Xen profile policy, rebooted the server and it works. This eliminates the new Image from being a problem...

  4. Tried some of the other steps outlined in this thread to no avail (restart Citrix GP service, changed program files registry key, etc).

Citrix tech support went and talked with the provisioning team and said they'd never heard/seen this before. Which may be true, this may be in a different area of their teams that recognizes this issue.

Bottom line, why is this happening with Group policy? Why can it not apply the Citrix policies after applying Microsoft policies?

share|improve this question

2 Answers 2

Can you run RSOP.MSC and see what the result is? This should assist in finding what may be conflicting/preventing the Citrix GPO

share|improve this answer
    
We have done this and the RSOP has come back with the Citrix policy showing as being applied, but the Citrix profile manager doesn't seem to catch it? –  Split71 Feb 29 '12 at 20:25
up vote 0 down vote accepted

Resolved this issue by finding a corrupt group policy being applied. Was able to reproduce this in a test server within the no policy OU/container.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.