Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Running RSH commands on a Windows box against a Linux box works only for the administrator user. Is there a file somewhere that has a list of users that can run commands remotely?

More Info

The server configuration is automated by VMware's product... There's no /etc/hosts.equiv file setup but there is a /root/.rhosts file with an entry of [IP ADDRESS] +.

The SUA client C:\Windows\SUA\bin\rsh can login when run as the local administrator account but no other user can login. The error is: rcmd: unknown user: [username]. The command I'm trying to run is: rsh -l root [IP ADDRESS] ls.

share|improve this question
2  
RSH? Seriously? The rsh/rlogin commands are insecure, and so almost everyone avoids them. –  Zoredache Mar 1 '12 at 0:57
    
This is a Very Bad Idea(TM) –  Jacob Mar 1 '12 at 1:03
    
The rsh protocol is not secure for network use, because it sends unencrypted information over the network, among other reasons –  Christopher Wilson Mar 1 '12 at 1:54
1  
Thanks for the security considerations guys... There's a product from VMware that uses it and I need to get it to work. –  Andy Arismendi Mar 1 '12 at 2:04

1 Answer 1

I agree with Jacob that this is a VBI, but the following should help you.

To rlogin/rcp/rsh to a machine without enter a password, you should have $HOME/.rhosts file defined on the target machine if you are trying to login as root. If you try to login as non-root, make sure the user is in /etc/passwd and the host you are login from is defined in either /etc/hosts.equiv or $HOME/.rhosts files. Both /etc/hosts.equiv and $HOME/.rhosts file should contain the host name that are allowed to connect. Optionally, you can associate a user name with that host name to narrow the permission to just those users. So, the format should look like th following line:

hostname [username]

Both rsh or rlogin prompt for a password. All you need to do is open /etc/hosts.equiv file on host system and add entries for all hosts you would like use without password .

This file list of hosts and users that are granted "trusted" r (rsh/rloging) command access to your system without supplying a password.

$ cat /etc/hosts.equiv

Output: Domain.com

a.domain.com

b.domain.com

In above file "a" and "b" hosts can connect without a password.

Caution: R (rsh/rlogin) commands are very insecure if possible switch to secure shell (ssh). You can configure ssh so that is does not prompt for a password.

=====

Based on your edits, I'm pretty sure that you are connecting from Server 2008 to an AIX box. I'll bet that since this worked fine in 2003, you are using the MS default install, which will NOT let you use a local user to rsh because of changes MS made to IPV6 in their SUA install (interix v6). Remember, Server 2003 did not have IPV6 enabled by default.

First, save yourself some time and disable IPV6 on the network adapter that you are using and see if this sorts everything out. If you need IPV6 (C'mon, really?!) you will need an updated package from interix (the guys who made the SUA for MS) so that you can get an "updated" version (actually IPV4 only) rsh version from Interix. There are 2 steps:

You need to have the installer pkg installed first and then you can add the package with the command "pkg_update -L rsh".

The pkg installer is not part of the MS installation. Refer to this web page for more information about pkg: http://www.suacommunity.com/pkg_install.htm

Make sure that you are logged in as a local administrator and that you run the package install and the pkg_update command from the sua prompt.

share|improve this answer
    
Are you using VMware workstation 5 or 6? Time to upgrade! –  G Koe Mar 1 '12 at 3:12
    
Thanks for the info @GKoe :-) I added some more information to my question. Please take a look –  Andy Arismendi Mar 1 '12 at 4:27
    
I bet you were using this on a server 2003 machine with no problems and now are having an issue in server 2008? You need a different version of the SUA. If you went to Programs and Features, enabled SUA and then installed the "Utilitiies for Subsystem for Unix-based Applications" pack from the Microsoft website, this is what is causing your issue. Please see my edited answer for additional help as I know some folks who had this problem in vista and server 2008. –  G Koe Mar 1 '12 at 4:40
    
Things used to work on 2003 indeed :-) Now on 2008 with SUA SDK and no worky :-( –  Andy Arismendi Mar 1 '12 at 4:52
    
Can you add the info that helped the folks on vista/2008 please? –  Andy Arismendi Mar 1 '12 at 5:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.