Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have two Netgear SRW224G4P switches with serial console ports. I'm using a Sabrent USB 2.0 to serial cable adapter with a female-to-female serial cable. I'm running Windows 7 64-bit and using putty to connect. However, nothing appears in the console window. I do not get a "press enter to begin" message, and if I press ender, nothing happens. There is no jibberish in the console window to signify the wrong baud rate. If I pull the power on the switches and let them start back up, I do not see any POST information.

The serial settings I'm using: COM3, 38400 baud, 8 data bits, 1 stop bit, parity off, flow control XON/XOFF.

As a comparison, I had all of this working with a different model switch--a Netgear SRW224P, so I know the cables are good, and putty is functional.

Is there a trick to connecting to a SRW224G4P switch's console port?

[edit]: I also tried the baud rates of 2400, 4800, 9600, 19200, 38400, 57600, 115200, and 31250. None of these rates seemed to work and all I got was a blank, unresponsive screen in the console.

share|improve this question
    
Not sure why it would be different, but have you tried other common buad rates? –  Zoredache Mar 1 '12 at 18:40
    
I tried all the common baud rates, and no success. –  Force Flow Mar 5 '12 at 20:48
add comment

1 Answer

up vote 1 down vote accepted

Flow control should be off - chaper 4 page 7 http://static.highspeedbackbone.net/pdf/linksys-SRW224G4P-manual.pdf

I've used both hyperterminal and putty for this.

Also I remember having some fun and games with a SRW248G4P - whatever I did I couldn't connect - tried a straight through cable, then modified it to cross over, then changed it to cisco rollover. However the cable didn't have all the pins populated so that possibly could have been the reason.

Luckily I found a flaw with the SRW248's - they would only operate at around 20Mb per port rather than 100Mb with certain NIC's so Cisco swapped it out for an SF300-48P. Again I tried my home made cable with no joy but the cable supplied with the replacement worked fine.

I've found a website that says it's just a normal straight through cable, but often cables aren't fully populated and I'm wondering if this could be an issue. http://techpain.blogspot.com/2009/06/linksys-console-settings-srw224g4.html

Also if you get no joy, see if you can use a proper serial port reather than usb converter.

As a side note, I very strongly recommend you do some testing of the switch - Get a server with decent RAID setup on to one of the gig ports, and some time when the server is under no/little load, copy a file from different PC's plugged into the 100Mb ports and see what happens.

With certain NIC's, I found speed dropped to 20% which could be improved to around 70% by turning on flow control on the switch, but after a short period this would cause lots of ports to stop working.

Cisco wished to verify the fault in their lab before acknowledging the fault - took a while for us to establish what common kit we had that would reproduce the issue - in the end we used Realtek 8139B with drivers updated to latest to prove the issue. The did swap both of ours free of charge although we had to pay postage to get our old ones sent to Belgium.

If you can get them to swap yours out, not only will this get it working at full speed, you will no longer have to wait half an hour for each GUI page to load.

share|improve this answer
    
I do not have any laptops with a serial port, unfortunately. Up until now, the USB converter has worked fine. According to the switch's manual, the correct baud rate is 38400, which doesn't appear to work. –  Force Flow Mar 5 '12 at 20:51
    
@ Force Flow : Have you tried turning flow control off as per the manual? Also have you got any servers near the switch with a serial port? Have you tried to SSH in? Also I do vaguely remember something along the lines of one of the switches stopping working on serial port until I reset it to factory via gui but that was a while back and my memory is hazy. –  Robin Gill Mar 5 '12 at 21:19
    
Yes, I turned off flow control. I have not tried SSH. I am unaware of what the current IP addresses or hostnames of the two switches are. –  Force Flow Mar 6 '12 at 13:50
    
Try something like solarwinds ip address tracker to check for devices that you can't recognise. If anyone has previously set device info such as location, I believe it uses SNMP to query these values which may help to find which ip it is on. –  Robin Gill Mar 6 '12 at 15:54
    
Nope, haven't found it. All the IP addresses on the current subnet are accounted for. Changing the host's IP and ccanning on the 192.168.1.x subnet didn't reveal anything. I was unable to connect with SSH with the switch's default IP address. –  Force Flow Mar 7 '12 at 17:57
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.