Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have program that reads/writes to a mapped drive. It works properly when accessing the mapped drive if I run it interactively (e.g. double click or command line), however it fails if run as a service. (Works fine as a service if I am only accessing local drives)

There is no difference in the program code being executed in either mode, only that it cannot access mapped drives as a service.

I have tested the service running as LocalSystem, LocalService, NetworkService, and set to login as the same user account used to run it interactively, none work.

Are there additional permissions to look for? I had thought having it run as a user it would inherit all of their rights.

Environment is Wondows Server with Active Directory accounts.

share|improve this question
Eric's answer solved the problem, however, since I can't force the mapped drives I altered the service to substitute the UNC path whenever it encounters the mapped drive path. – quick_dry Mar 2 '12 at 2:02
up vote 2 down vote accepted

Not trying to be short, but i think this will answer your question.

See the one about using the Sys Internals tools

share|improve this answer
thanks Eric, that got me onto it. – quick_dry Mar 2 '12 at 2:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.