Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have one of these:

http://www.supermicro.com/products/motherboard/QPI/5500/X8DTG-QF.cfm

And IPMI is just not operating anymore, it had been at one point. It comes up as non functional in the BIOS (i.e. "Status of BMC Not Working" & "IPMI Firmware Revision 0.02") and causes the boot process to wait for ages. I can't seem to disable it altogether. I want to try flashing the IPMI Bios as it would be handy if it worked, but the instructions seem to be very poor to entirely missing.

I download the IPMI firmware file which is said to contain instructions but I am presented with an IMA file inside a compressed zip image. Unfortunately, the IMA file is not what it appears. It's not a win image file as I first thought... win image doesn't recognise it.

There are multiple instructions and various utilities floating about the supermicro website. But no clear direction on which one to use. I did find some dos utilities for other motherboards on the website.

Has anyone done this before? where do I start?

share|improve this question
    
    
@Rob Moir - No, different problem, different bios. –  Matt Mar 2 '12 at 18:04

2 Answers 2

Welcome to Supermicro, where the docs are inconsistent and often wrong. What I typically end up doing is digging around on ftp://ftp.supermicro.com until I find something that seems useful.

In your case, I'd suggest you check for upgrades to the actual BIOS before you try anything else. The IPMI BIOS and the real BIOS appear to be closely linked, and upgrading the real one may help.

From there, I'd suggest you take a look at the tools in ftp://ftp.supermicro.com/utility/ , one of them will probably work for you, even though none explicitly claim to support your motherboard. The 'IPMI FW flash tools' directory is probably where I'd start.

I should note that it's possible to brick the motherboard or IPMI controller by using the wrong firmware flash tool. The only people that can tell you which tool is actually correct is Supermicro themselves.

share|improve this answer
    
Haha this is exactly what I do when looking for the IPMI tool. None of their links on the website are correct, but you can generally find it inside their FTP site. –  Mark Henderson Mar 3 '12 at 4:48
    
Thanks, I tried a couple of the flash tools but none of them worked. I think I do actually have a bricked IPMI firmware. –  Matt Mar 5 '12 at 22:59
    
Seeing as it appears to be bricked, do you know if there is a way to disable IPMI BMC altogether? I can't see such an option in the BIOS and the motherboard manual doesn't describe any jumpers that do it. –  Matt Mar 5 '12 at 23:01
    
I don't really think that's possible. The IPMI controller is very tightly integrated into the ethernet controller, and video, and USB, etc. I can't really see any way you could completely disable it. Can you RMA the board? That would be the only option afaik. –  devicenull Mar 5 '12 at 23:41

I know it is old question but might help someone. Had similar problem "Status not working". Found out that BMC was not enabled on motherboard itself (wrong jumper settings)(JBMC1 on my MB X8ST3-F). Also worth mentioning is part from IPMI manual (in my case IPMI Manual (AMI)) regarding:

  1. Enabling COM Port for SOL (IPMI)
  2. Enabling All Onboard USB ports

References: Super Micro IPMI Guide

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.