Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm attempting to add some of our LDAP users to a locally defined group on our RHEL server, however I get an error stating that the LDAP user is not found in /etc/passwd.

What would be the best way to allow LDAP users to be added to local groups?

My feeling is that this must be done manually. I could edit: /etc/group and add the LDAP group to the list. Would that be ideal?

[server]# id apache
uid=409(apache) gid=409(apache) groups=409(apache) context=user_u:system_r:unconfined_t:s0
[server]# id john.doe
uid=11389(john.doe) gid=6097(ABC_Corporate_US) groups=6097(ABC_Corporate_US) context=user_u:system_r:unconfined_t:s0
[server]# /usr/sbin/usermod -a -G apache john.doe
usermod: john.doe not found in /etc/passwd

OS: RHEL (Red Hat Enterprise Linux Server release 5.3 (Tikanga)) Note: Updating the OS on this machine is not an option.

share|improve this question
    
Why not create an LDAP group? –  Mei Mar 2 '12 at 18:37
    
@David, that's a pretty generic question, can you clarify? –  Highway of Life Mar 3 '12 at 1:47
    
There are LDAP schema that support UNIX groups; if you use those, then you don't have to mess with on-system UNIX groups at all. –  Mei Mar 5 '12 at 15:57

2 Answers 2

Your version of usermod doesn't support LDAP. This was fixed in newer versions of RHEL:

http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/html/5.5_Technical_Notes/shadow-utils.html

share|improve this answer
    
That means he could probablu edit /etc/group manually to add the users then? –  Yanick Girouard Mar 2 '12 at 19:23
    
While this may be true that the current version is out of date, it doesn't really answer the question (which is: How do you get around it in the current version posted?). I may not have permission to update RHEL. –  Highway of Life Mar 3 '12 at 1:43
up vote 2 down vote accepted

I discovered that this can be achieved using the gpasswd command.

gpasswd -a john.doe apache
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.