Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am not sure if this is down to libapache2-mod-auth-kerb, apache2-mpm-itk or apache2 in general. The error message itself is very cryptic:

access to / failed, reason: 
       user 'd_inevitable' does not meet 'require'ments for user/valid-user to be allowed access

I am trying to create a development server for all development users. First I have tried to use a single virtualhost for it: without success. No am setting up a new virtual host for each user.

A virtual host for a user looks like this:

    ServerAdmin d_inevitable@lan

    ServerName dinevitable.userspace.lan
    ServerAlias *.dinevitable.userspace.lan

    AssignUserId d_inevitable devel

    DocumentRoot "/home/users/d_inevitable/workspace"

    <Directory "/home/users/d_inevitable/workspace">
            AllowOverride All

            Options Indexes FollowSymlinks SymLinksIfOwnerMatch

            Order allow,deny
            allow from all

            AuthType Kerberos
            AuthName "Kerberos LAN Realm Login"
            KrbAuthRealms LAN
            Krb5KeyTab /etc/apache2/auth/dinevitable.keytab

            KrbMethodK5Passwd On
            KrbSaveCredentials On
            KrbLocalUserMapping On

            Require user d_inevitable;

    SSLEngine On
    SSLCertificateFile /var/secure/ssl/userspace.lan.crt
    SSLCertificateKeyFile /var/secure/ssl/

Each user has it's own HTTP keytab on the server so that there are no file-permission errors.

Well other than wondering how to fix it, I also wonder what this message means...

share|improve this question
up vote 1 down vote accepted

Semicolons aren't syntax in Apache configuration. Your Require user d_inevitable; literally requires the username to be d_inevitable;, while your user is named d_inevitable.

Remove that semicolon and the user should have access.

share|improve this answer
I have literally spent 4 days figuring this out!!! Man thank you very much. I know there should be no semicolon, but as a programmer I don't see these anymore... – d_inevitable Mar 2 '12 at 20:47
It happens - all the different syntax types start to blue together for sure. – Shane Madden Mar 2 '12 at 20:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.