Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have MariaDB running on my dev server (no replication or anything else) running version 5.3.5. It's an Ubuntu 10.04 server running all the latest patches and updates. I am having issued getting errors regarding the the binlog_format, so I went to change it from STATEMENT to MIXED or ROW, but when I run SET GLOBAL binlog_format = 'MIXED', nothing gets updated. I have tried everything from this post: http://dba.stackexchange.com/questions/6150/what-is-the-safest-way-to-switch-the-binlog-format-at-runtime, but nothing changes. The only way I have gotten it to change is with the following:

sudo service stop mysql
sudo mysqld --binlog_format=MIXED

The only problem is that when I restart the format goes back to statement based. Is there anything else I am supposed to do to change it as a global variable?

share|improve this question
add comment

1 Answer

I was able to fix the problem by adding binlog_format = MIXED to my my.cnf file. I hadn't tried that before, because I didn't see it setting the format there, but when I added it near all of the other binlog settings and restarted the service, it worked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.