Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I don't know if this type of question belongs to ServerFault or SuperUser.

If I mess with the source partition (eg. deleting and recreating a bigger partition) where the OS was originally installed, when restoring the partition from an image in sda2 using Clonezilla, Windows will complain and be unable to repair. I sometimes get error 0xc0000225, sometimes will just enter an endless boot/reboot cycle.

I also tried booting from the DVD and using the Repair procedure, to no avail.

A restored Ubuntu works just fine, so it looks like Windows is more picky.

Does someone know what can cause this and what can be done about this?

Thank you.

After hitting the Repair option in the failing Windows, it runs for about 15mn, and fails with the following error message:

Root cause found:
Unspecified changes to system configuration might have caused the problem.

Repair action: System files integrity check and repair
Result: Failed. Error code = 0x490
share|improve this question
Have you tried using gparted or something like that to expand the partition to fill the rest of the disk? – Phillip R. Mar 7 '12 at 18:44
I'll give it a shot, thanks. – user15318 Mar 16 '12 at 12:43

If this is Windows Vista or Windows 7, you may be restoring the Windows partition without the small (~95mb) System partition.

If you've just resized the partition, the identifier might have changed, and you may need to adjust the boot settings in the BCD.

share|improve this answer
The boot partition (100 or 300MB before formatting) is almost certainly the problem, he only mentions the system partition. – Chris S Mar 18 '13 at 12:52

I think that you are kill the Master Boot Record when you are recreate partition.

Using Clonezilla to copy disk to disk will include the mbr. Copying partition to partition to partition will not since the mbr is not on any partition.

share|improve this answer
Thanks for the tip, but Clonezilla does save the MBR even when saving a single partition, just in case. It looks more like a Windows issue. – user15318 Mar 7 '12 at 10:38

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.