Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have an instance mic with ubuntu 10.04 installed without problems, super fast for me, the problem is that I want to install Virtualmin being discharged to go my new sites. When I configure bind to generate the nameservers (ns, ns2) first I can not change the hostname for a FQDN and not see the option to change it. The assigned IP and bind the name generated for areas not applicable (I am new to this set also bind and areas).

Amazon ec2 The truth is great, great but the set is a bit messy, someone who was able to install and configure bind9 bind9 with Virtualmin or alone, there is a manual for this. I need someone who has been there can help me.

If no solution at the end I will have a conventional vps and would be a shame because amazon is great.

The configuration is generated bind this.

$ttl 38400
@   IN  SOA ip-10-243-63-218. root.ip-10-243-63-218. (
38400 )
@   IN  NS  ip-10-243-63-218.    IN  A    IN  A    IN  A  IN  A  IN  A    IN  A  IN  A   IN  A    IN  MX  5    IN  TXT "v=spf1 a mx ip4: ?all"    IN  NS    IN  NS IN  A   xx.xx.xx.xx    IN  A   xx.xx.xx.xx

The doubts I have are that it should go here:
@   IN  SOA ip-10-243-63-218. root.ip-10-243-63-218.
@   IN  NS  ip-10-243-63-218. internal ip
xx.xx.xx.xx is my ip elastic


share|improve this question
Its really hard to see what your question is. Please make this clearer or it is liable to be closed. – Sam Mar 3 '12 at 18:19
Sounds like machine translation to me. Hard to understand. – Sandman4 Mar 3 '12 at 19:03
There are defiantly plenty of people who have installed DNS servers in the amazon cloud. But like Sam said, not really sure what your question is so I can't really help out too much. – bwight Mar 3 '12 at 19:03
Sorry for my english :( What i need is to configure bind with amazon ec2, what is the best way to configure it, a tutorial to do the best possible way. – Alexd2 Mar 3 '12 at 20:36

1 Answer 1

Ok I left out a lot of your records because it really isn't important to the question. I also haven't configured a slave server. Since it seems you're kind of new using bind we need to start with the basics. Once you get the basics working you can try to implement your working solution. Tested this solution with Amazon Linux you might need to change some directories using ubuntu i'm not sure.

For this configuration you'll use two files

  1. /etc/named.conf
  2. /var/named/

Contents of /etc/named.conf

options {
    listen-on port 53 {; };
    listen-on-v6 port 53 { ::1; };
    directory       "/var/named";
    dump-file       "/var/named/data/cache_dump.db";
    statistics-file "/var/named/data/named_stats.txt";
    memstatistics-file "/var/named/data/named_mem_stats.txt";
    allow-query     { localhost; };
    recursion yes;

    dnssec-enable yes;
    dnssec-validation yes;
    dnssec-lookaside auto;

    /* Path to ISC DLV key */
    bindkeys-file "/etc/named.iscdlv.key";

logging {
    channel default_debug {
            file "data/";
            severity dynamic;

zone "." IN {
    type hint;
    file "";

zone "" {
    type master;
    file "";

include "/etc/named.rfc1912.zones";

Contents of /var/named/ ( replace with your private ip )

$TTL 43200     IN      SOA (
                            1 ; serial
                            21600      ; refresh (6 hours)
                            7200       ; retry (2 hours)
                            1209600    ; expire (2 weeks)
                            43200)      ; minimum (12 hours)            NS
ns01                    A

Now locally you can run the command host

[root@domU-12-31-39-09-FA-A8 ~]# host
Using domain server:
Aliases: has address

Let me know if you're still having problems or if this configuration isn't doing what you expected.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.