Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I cannot start apache on xampp, it says Busy...

I have googled this many times and I have tried the following solutions:

  1. Skype no longer uses port 80/443
  2. Teamviewer no longer uses port 80/443
  3. Adding the NoRun key to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP (Solution found here)

But none of these work, when I visit localhost on a browser it will load but just give a blank page, even thought apache isn't started.

I have also run netstat -ano on command prompt, I get the following entries using port 80:

TCP 0.0.0.0:80 0.0.0.0:0 LISTENING 4 and TCP [::]:80 [::]:0 LISTENING 4

Both are being used by PID 4 which is System when I look it up in task manager.

I have also googled around and seen that this may be caused by VMWare which I have installed but I cannot seem to find a solution for this, can anyone help me with this please. If you need more information then please comment and I will add it.

EDIT:

After running the beta control panel, I get the following in the logs:

12:57:41 [apache] Possible problem detected: Port 80 in use by "system"! 12:57:41 [apache] Possible problem detected: Port 443 in use by "vmware-hostd.exe"!

share|improve this question

3 Answers 3

up vote 3 down vote accepted

In VMware go:

Edit < Preferences < Shared VMs

and Disable Sharing (or change the ports if you need the functionality)

share|improve this answer

Try running TCPView from Microsoft sysinternals. It will show you a detailed list of all TCP and UDP endpoints on your system ... It can also report the name of the process that owns the endpoint.

Update: If you can't find the program running on that port, it might be a solution to simply change the port of XAMPPs Apache. The directive you need to change is Listen 80. Maybe set this to 8000 instead and point your browser to http://localhost:8000/.

Another thing you can try is -if you have VMware installed (Server?) - to check the Windows services panel and try to shut it down there as I suppose it is a service.

share|improve this answer
    
I cannot find anything which is using port 80 in either the local or remote port columns. –  Daniel B Mar 4 '12 at 12:55
    
I updated my answer. If you shut down the service, you might not need to change any directive as mentioned above. –  Chris Mar 4 '12 at 13:07
    
I have changed the port in httpd.conf and that seems to be working now, thanks. –  Daniel B Mar 4 '12 at 13:09

You need to install apache server as a system service (from the apache control panel) - then restart the machine.

You might also need to kill off other processes occupying port::80...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.