Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm working on deploying my first rails app to my mediatemple(dv) and i'm first trying to install RVM using this command:

bash -s stable < <(curl -s

and I get the following error:

curl: (60) SSL certificate problem, verify that the CA cert is OK. Details:
error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
More details here:

curl performs SSL certificate verification by default, using a "bundle"
 of Certificate Authority (CA) public keys (CA certs). The default
 bundle is named curl-ca-bundle.crt; you can specify an alternate file
 using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in
 the bundle, the certificate verification probably failed due to a
 problem with the certificate (it might be expired, or the name might
 not match the domain name in the URL).
If you'd like to turn off curl's verification of the certificate, use
 the -k (or --insecure) option.

Could not download ''.
  Make sure your certificates are up to date as described above.
  To continue in insecure mode run 'echo insecure >> ~/.curlrc'.

It looks like I should be able to specify -k/--insecure to skip the certificate check, but how can I do that? I'm kind of a linux rookie.

share|improve this question
You can put "-k" after the "curl" and before the "-s". – cjc Mar 4 '12 at 19:52
up vote 3 down vote accepted

Did you read the error message properly ? The last line in that message has the solution.

echo insecure >> ~/.curlrc

Run the above in your shell and rerun the RVM installer.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.