Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have apache with the following 000-default file for my app

   <VirtualHost *:80>
      ServerName www.yourhost.com
      DocumentRoot /somewhere/public
      <Directory /somewhere/public>
         AllowOverride all
         Options -MultiViews
      </Directory>
   </VirtualHost>

I've restarted apache and now I get You don't have permission to access / on this server. when browsing to it.

Does anyone know what permissions to my app or if I have to add the app folder to the wheel group or something like that?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Try adding Allow from all to the <Directory> stanza. Also, don't edit 000-default; use your own vhost config file in sites-{available,enabled}.

share|improve this answer
    
I was also getting error 403, so I chowned to www-data:www-data is that right? –  Joseph Le Brech Mar 4 '12 at 20:45
    
No, you should just set permissions so that the webserver can read the files -- usually o+x on the leading directories and o+r on the files themselves should be sufficient. –  womble Mar 5 '12 at 0:44

To be able to browse through the directory structure you need to add the Indexes to Options so it reads

Options Indexes -MultiViews

And to answer your comment, yes the directory structure should be chown'ed to your webservers user. However be careful assigning stupid permission sets (e.g. 777) on the directory. There is no case where you'd require this if your webserver user (or group) is set correctly.

For rails to work you will however need more. Lookup for mod_passenger within your distribution. This is the connecting module for Ruby. Without that you most certainly will only be able to browse the code, not the app.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.