Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server setup with FreeBSD 8.2-STABLE running Apache/2.2.22.

Since this morning it became very slow. Connections are quickly established, but the response is very slow. This is valid even for regular files (not scripts) such as images, css and so on. I can't figure out, what could have happened since yesterday. I didn't change any configuration. The usage of netstat and top to make some profiling don't show anything unnormal - everything looks good. The system idles almost 100% of the time and the number of incoming connections is not so high.

What can I do to determine the reason for the slowing down?

share|improve this question
    
Did you check for free space already? Try df -h to see if maybe your HDD is full. This might be caused by huge logfiles, etc. And it can slow down your server to the point of unavailability. –  Chris Mar 5 '12 at 15:01
    
Thanks for suggestion, I've checked it - more than 60% is available. –  heximal Mar 5 '12 at 15:22
add comment

1 Answer

up vote 2 down vote accepted

Is DNS resolution is turned off ? If not, then do it. Note, that you need to disable it also in your logformat, not just "HostnameLookups Off" Check your logformat, or put your logging configuration here for further info.

share|improve this answer
    
brilliant!!! thank you very-very much! –  heximal Mar 5 '12 at 15:31
    
You are very welcome –  Gabor Vincze Mar 5 '12 at 21:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.