Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got two identical procurve 2610-24/12PWR switches with the web interface configured. I can log in to one and see all the management info just fine. When I load the web interface of the other I'm asked to authenticate as usual and the various java applets that comprise the page start to load. Then they all fail concurrently and generate a pile of ClassNotFoundExceptions in the java console.

What gives? The switch appears to be operating normally otherwise.

share|improve this question
    
Have you rebooted the switch recently? This happend to me and the web server had locked up. –  t1nt1n Mar 5 '12 at 16:49
    
I haven't rebooted it, no. The other switch shows uptime of 213 days so I presume this one is the same. The management interface was working last week... unfortunately unless these java applets load I can't even reboot remotely - catch 22! –  Josh Mar 5 '12 at 18:19
    
Did you enable the telnet interface? In fact I think It's on by default –  t1nt1n Mar 5 '12 at 18:53
    
You're right, I can telnet in. I'm a little hesitant to reboot now though, just in case it doesn't come back up cleanly... –  Josh Mar 5 '12 at 19:24
    
I've resolved to wait until that site closes then issue a reload via telnet. –  Josh Mar 5 '12 at 20:57

1 Answer 1

What operating system, web browser, JRE and firmware version are you using?

We have dozens of 2600 series switches and we haven't seen any issues with the Java applets embedded in their web interface. For the records we're using R.11_72 firmware on our switches and the web interface works fine in Firefox 10.0.2 with Java 1.6.0_27.

I would try upgrading to the most recent firmware available for your switches (probably R.11.72) and make sure your web browser and Java is updated and configured appropriately. Have you tried using different browsers?

If all this fails, you should take advantage of ProCurve's free lifetime support and call HP.

Lastly, unless you have specifically disabled it you should still be able to manage your switches via the console.

share|improve this answer
    
win2k3 sp2, chrome 17.0.963.56, java 1.6.0_31, firmware R.11.30. –  Josh Mar 5 '12 at 19:24
    
Also, the other switch (same exact configuration on all accounts) works fine. The java applets on this one are just borked. –  Josh Mar 5 '12 at 19:26
    
Have you tried a different browser? –  kce Mar 5 '12 at 19:38
    
Yep, same error in IE. –  Josh Mar 5 '12 at 19:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.