Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a Wordpress blog that is outside our network, hosted by Apache. When I send test emails from the blog, we receive email when they are sent to Hotmail and Gmail, but we do not receive email when sent to our domain which has an Exchange 2007 server, and Forefront. We also have Postini in the cloud filtering email before it gets into our network.

The server that has our Wordpress blog is shared, so I do not think I have access to the error log or much of anything on that server. But I have total access to our Windows network.

How can I find out what blocked the email? Neither Postini or our internal AV acknowledges blocking it. Is there any monitor or log in Exchange 2007 that would report blocking an email?

Maybe I'll never know, but is there at least some monitor in Exchange 2007 I can view?

share|improve this question
add comment

1 Answer

This is a Postini issue. It throws out messages claiming to be from the domain which it is protecting, so if your blog is sending as blog@example.com to you at me@example.com, postini throws it out.

It does this to prevent spam which imitates the receiving domain (ever gotten spam from yourself in the past? This helps prevent that.)

I'm looking into this for a client right now, trying to make an Expression Engine install play nice with Postini. I'll update if I find a solution.

In the meantime, here is a link I've found with a little bit of discussion on the issue. I'm not sure I'd try their MX approach but it's the closest I've seen to a solution. (Disregard the discussion of SSL at the top of the thread).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.