Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a ASP.Net MVC 4 application we are trying to deploy to a Windows 2003 machine running IIS 6. We have it running on a separate app pool and it is setup to use asp.net 4.0. We have a Wildcard application mapping to aspnet_isapi.dll which was required to get the page to appear.

The problem we've ran into now is that the bundling which is part of asp.net mvc 4 isn't working. When you try to follow the /js?v=ASDfljkFSDlkjDSF link you get a 404 returned to you.

We know it uses extensionless urls but these should be handled by the Wildcard application mapping if I'm not mistaken?

Has anyone got this working or have any ideas?

share|improve this question
    
Please be a little more elaborate on the details than just "isn't working". error codes? logs? –  Mathias R. Jessen Mar 5 '12 at 18:13
    
Ahhh yes right.. thanks for pointing that out. We'll call that a Monday brain fart :) –  ShaneC Mar 5 '12 at 18:20
add comment

3 Answers

I know this was a while back but I had this issue on an web forms app using bundle tables. It worked as it's own site and didn't under a virtual directory. IIS had no idea where to get the bundles (as ShaneC said).

In the properties of the virtual directory --> Configuration --> Mappings I inserted a wildcard entry to "C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll" and unchecked the verify that file exists.

This worked for me.

share|improve this answer
add comment

IIS6 won't know which handlers to serve the request for an extension URL like /js?blahblahblah, so it assumes the file is static, looks for it, can't find it, and returns 404.

Check out this post for a workaround

share|improve this answer
    
That post assumes there is an extension in the url at some point (axd in the post). With ASP.Net 4 bundles there is no extension you can latch onto to do that kind of thing. –  ShaneC Mar 5 '12 at 18:49
add comment

The problem was that we were running as a Virtual Directory configured for ASP.Net 4.0 under a Default Web Site which was configured for ASP.Net 2.0.

We created a new web site and set it to asp.net 4.0 and everything worked perfectly. As per this post on Haacked extensionless urls should just work on most instances of IIS 6 now.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.