Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I need to link a branch office to a new subnet. I'm doing something wrong. I try to be more specific:


I have this object virtually connected as follows:

GW_U ---- S-OpenVPN ----- OpenVPN-C ----- GW_S

where:

GW_U: main office gateway with Linux OS on which here is a the VPN server (OpenVPN-S) , a DHCP for the internal network 192.168.10.x and a firewall IPTables.

GW_S: gateway of the branch office with OS Windows 2003 Server, a VPN client (OpenVPN-C) and a DHCP for the subnet 192.168.8.x

Nodes IP in the network are as follows:

GW_U: 192.168.10.254
OpenVPN-S: 10.8.0.1
OpenVPN-C: 10.8.0.2
GW_S: 192.168.8.254

The VPN works fine but I can not to connect the two sub-networks (although I set the routing). Really I can operate only in one direction by enabling the masquerading (of GW_S) from one of the interfaces. If I enable masquerading on both interfaces (of GW_S) does not work!

On the Linux gateway (GW_U) I can enable the masquerading of all interfaces without problems.

I add some screenshot of the configured routing table and of NIC:

Routing Table (with my static routing) configuration: http://img52.imageshack.us/img52/4702/74261.jpg

NIC configuration: http://img21.imageshack.us/img21/1164/74263.jpg

share|improve this question

migrated from security.stackexchange.com Mar 5 '12 at 18:46

This question came from our site for Information security professionals.

    
tnx for the image! :P –  Gabriele Pia Mar 5 '12 at 17:00

1 Answer 1

up vote 1 down vote accepted

I solved, I installed Linux! LOL! :P

and... this is not a "giving up" this is the only solution... in windows you can't enable Masqueraging on two "external" interfaces...!!! you need to have at least one "internal" interface.

and i think that THAT ANSWER can help other people with the same problem...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.