Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to mount windows machine directory in my ubuntu 10.04.3 server. When I try to see the shared directory in the windows server its showing properly using the below command. The windows mahcine is joined to local domain xyz.com

My doubt is, cant we mount the shared directory which is connected to local domain server? I am getting this error in both smbfs / cifs.

 smbclient -L // -U svnbackup

    Sharename       Type      Comment
    ---------       ----      -------
    ADMIN$          Disk      Remote Admin
    Android         Disk
    C$              Disk      Default share
    CENTOS          Disk
    E$              Disk      Default share
    G$              Disk      Default share
    IPC$            IPC       Remote IPC
    Nagios          Disk
    test            Disk

When I try to mount the test directory using below command Its show error saying permission denied as below.

  mount.smbfs // /mnt/smbfs -o username=username,password=Svn1234,domain=xyz.com
  mount error(13): Permission denied Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Please help me to solve the issue.

share|improve this question
I hope that's not your actual password there. There's also a discrepancy between the IP address at the top of your question and the IP address at the bottom. –  Ladadadada Mar 6 '12 at 10:15
Even I created a local user & tested, In that also I am facing same issue. Oh!! thats a typo error –  Caterpillar Mar 6 '12 at 10:17
It might be bugs with the kernel, try to upgrade the kernel and check it –  Mughil Mar 6 '12 at 10:25
Upgraded to 2.6.32-39 –  Caterpillar Mar 6 '12 at 10:32
Can you confirm what user you're running the mount command as and that the /mnt/smbfs has the correct permissions. You need root permissions to mount filesystems unless the correct options are specified in /etc/fstab (user). –  webtoe Mar 6 '12 at 11:35

3 Answers 3

up vote 2 down vote accepted


mount -t cifs //address/sharename /mnt/whatever -o username=DomainName/username,password=password

if it doesnt work, try:

mount.cifs //address/Share /mnt/share/ -o username=address/username

dont add a password, it should prompt u for one and possible it'll work, gl

share|improve this answer
Thanks buddy, mount -t cifs //address/sharename /mnt/whatever -o username=DomainName/username,password=password This worked :-) Saved my life. –  Caterpillar Mar 8 '12 at 13:48
glad i could help :) –  3a2roub Mar 8 '12 at 15:11
That worked! But I am trying to access a folder which is publicly shared and not password protected. But it still asks for password. Any suggestions? –  zengr Mar 22 '13 at 22:28

Try cifs, smbfs is deprecated by cifs-utils & smbfs is used in Debian <= 3

mount -t cifs // -o username=username,password=Svn1234,domain=xyz.com /mnt/smbfs

share|improve this answer
mount -t cifs // -o username=username,password=Svn1234,domain=xys.com /mnt/smbfs/ mount error(13): Permission denied Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) –  Caterpillar Mar 6 '12 at 10:33

I've found solution on this site: http://ubuntuforums.org/showthread.php?t=1634635

Generally in Windows you should add this key in regedit. It works for me now. Key goes in: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Policies\System

Key DWORD (32-bit): LocalAccountTokenFilterPolicy Key Value : 1

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.