Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'd like to install the new PHP 5.4 on my Windows machine. I'm running Apache 2.2 on it. Reading the info on http://windows.php.net/download/, it says "If you are using PHP with Apache 1 or Apache2 from apache.org you need to use the VC6 versions of PHP". I guess I'm in that case, I just donloaded Apache from apache.org.

However, there are no VC6 versions available of PHP 5.4, not even of PHP 5.3. How can I install PHP 5.4 on my Windows machine then ?

share|improve this question

1 Answer 1

You needed to keep reading a bit further down the page.

"VC9 versions of Apache can be fetched at Apache Lounge. We use their binaries to build the Apache SAPIs."

Just be sure to get the 32 bit version on the download page.

share|improve this answer
1  
I did read that, but does that mean that I need to install an unofficial version of Apache just to be able to run it with PHP ? –  user410932 Apr 12 '12 at 7:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.