Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to tune my vSphere 5 and virtualized SAN for performance, but the network adapters for all networks seems to be stuck at 100Mb Full duplex instead of 1000Mb Full duplex. Does this mean that all communications between VM's on the all virtual networks is stuck at 100Mb full duplex, even though many VM's use the vmxnet3 drivers? How can I fix this?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Communications between virtual machines on the same vSwitch on the same box will be very fast and will not traverse the physical uplinks unless they are assigned to separate port groups that use an upstream device for inter-vlan routing. If your physical links are showing 100Mb, then your issue is probably the physical switch those NICs are connected to.

share|improve this answer
    
How fast is very fast? The only traffic going to the physical nic at the moment is for the vSphere Client, everything else is interal. –  cmaduro Mar 6 '12 at 15:27
    
That's a good question, even though each guest will show that it has a 1Gb link, I think it will go well over 1Gb in throughput internally since the latency won't climb. Perhaps someone else knows how fast it will go. –  SpacemanSpiff Mar 6 '12 at 16:21
    
If you're using VMXnet 3, you're going to get UP TO 10Gb connectivity from guest to guest, but keep in mind with a single host you're probably going to be constrained by disk I/O before you hit a "networking" limitation, but maybe not if you're using FLASH or SSD storage. –  SpacemanSpiff Mar 6 '12 at 20:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.