Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have an Exchange 2007 server that has Webmail setup. The issue is that users are sending files around the 20MB mark in size (unfortunately a necessary evil, but most of those being sent are internal); the issue is that when they're sending from the web interface they are unable to send attachments around that size.

I increased the Transport Limits (on the Hub Transport) to 26,000KB for max send/receive sizes.

Are there any other areas where I need to set up larger sizes - or will the Hub Transport sizes alone do it?

share|improve this question
1  
If it's internal...why not have a share where files are saved and accessed by your internal users? –  Bart Silverstrim Mar 6 '12 at 15:54
    
Good idea Bart - definitely a suggestion I could offer up. I'm not exactly sure what these particular users do or who they send things to so I think they eventually do external... but from what I could tell from the screenshots it looked internal for at least the few emails I saw. –  Hanny Mar 6 '12 at 16:17
    
Depending on the usage case, I usually try to avoid misusing email as a file transport whenever possible. If it's internal, I have people put it in shares. If it's not confidential, I would put it into a section of the web server for transfer, or use a service like Drop Box to share documents. Or create a website with logins to allow outsiders to download from a special link. Something that doesn't clog email inboxes, when possible. –  Bart Silverstrim Mar 6 '12 at 16:59
    
Definitely a better option - I will be pushing for that going forward. Thanks for the useful information! –  Hanny Mar 6 '12 at 17:44

1 Answer 1

up vote 0 down vote accepted

Outlook Web Access is an application that uses ASP.NET and is affected by the configuration of ASP.NET settings. ASP.NET uses the maxRequestLength setting to determine the maximum amount of data that the Web browser can submit to the Client Access server. The maxRequestLength setting is located in the Web.config file.

To change the maxRequestLength value

  • Find the Web.config file on the Client Access server. The default location is \Program Files\Microsoft\ExchangeServer\ClientAccess\Owa.

  • Make a backup copy of the file.

  • Use Notepad or another text editor to open the original file. Do not use Internet Information Services (IIS) to edit the Web.config file.

  • Find the maxRequestLength value, and change it to the value that you want. The value is in kilobytes (KB), and the default value is 30000. The following example shows the maxRequestLength value in the Web.config file:

  • Save and close the file.

share|improve this answer
    
Exactly what I was looking for. The user was insistent that those web services were the culprit - they weren't; but I wanted to make sure I had ruled that out and this was exactly what I was looking for! –  Hanny Mar 6 '12 at 16:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.