Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running into some issues trying to install hamachi v1 on a centos 6 64 bits server. I know that version is pretty old, but I need it to connect to a windows server which I don't have control on and only has hamachi v1 installed on it, and since it seems that the v1 and v2 networks are incompatible, I don't have much choice. I didn't know this however and installed v2 on the server first from here, which had no problems at all but of course couldn't connect to the network I wanted.

Anyway, as I read somewhere that centos has support for both 32 and 64 bits binaries, I thought that I could follow this guide to have it running. However, even when I can compile tuncfg and make install seems to work without problems, hamachi doesn't work at all. Running the commands hamachi or hamachi-init gives me nothing at all: no output and no error messages.

Thanks in advance.

share|improve this question
1  
CentOS6 64 is supposed to be able to run 32 bit applications as well, but in the case of Hamachi v1, it looks like you are out of luck. I have run Hamachi 1 in Ubuntu 64, but centOS will be more challenging. Ubuntu has ia32-libs to allow 32 bit apps but CentOS doesn't have the debian friendly ia32-libs that you could just install. –  G Koe Mar 10 '12 at 6:12
add comment

3 Answers

up vote 0 down vote accepted
+50

You can download and install the beta for hamachi v2 from here:

https://secure.logmein.com/welcome/labs/

The 64 bits rpm package runs pretty well on centos 6, and I just tested it and seems to connect to v1 clients without problems.

share|improve this answer
add comment

As far as I know Hamachi needs a Kernel module. A module that is precompiled 32bit or which can't be compiled on your 64bit arch won't work. This is probably why it just exits without giving any message, and frankly won't be solvable unless there is a 64bit package of Hamachi1.

share|improve this answer
    
thanks, I think they didn't going to release a 64bit version of Hamachi v1 :/ –  eveevans Mar 12 '12 at 17:42
add comment

Without knowing what dependencies Hamachi v1 is looking for, it will be difficult to help you.

I think the ia32 libs are part of the redhat-lsb.i686 package.

If you are brave, try:

# yum install compat-libstdc++-296.i686

and

# yum install compat-libstdc++-33.i686

And see if that will let you run Hamachi as they should give you the libraries that you need.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.