Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I created a new instance of a Gentoo AMI (Gentoo_64-bit-EBS-2012-03-02-07-39-15 (ami-6ab26f03)).

Both Status Checks passed (both system and instance reachability passed).

I know the Key Pair Name is correct, because I used the same keys to connect to the default Amazon Linux (amzn-ami-2011.09.2.x86_64-ebs (ami-1b814f72)).

This is what the verbose mode of SSH says (replaced the IP info with

hobbes3@hobbes3:~/.ssh$ ssh -v
OpenSSH_5.6p1, OpenSSL 0.9.8r 8 Feb 2011
debug1: Reading configuration data /Users/hobbes3/.ssh/config
debug1: Applying options for *
debug1: Reading configuration data /etc/ssh_config
debug1: Applying options for *
debug1: Connecting to [] port 22.
debug1: connect to address port 22: Operation timed out
ssh: connect to host port 22: Operation timed out

Is there something else I can do to see what the problem could be? Because operation timing out is a very vague output.

share|improve this question
up vote 4 down vote accepted

This sounds like a firewall issue to me. Can you verify that port 22 is open on your instance? I have never used Amazon as a provider, but I found some instructions for creating a security group which sounds like the right direction.

share|improve this answer
+1 -- make sure you have a security group that permits SSH to your hosts. I ran into this problem when I setup my first host. – Jeff Ferland Mar 6 '12 at 23:03
@JeffFerland - Glad someone with some Amazon experience could back me up. :) – Ek0nomik Mar 6 '12 at 23:05
Thank for the response. Your comment seems to have solved the problem. I created another instance with a security group from "default" to "quicklaunch-1", which was also the same security group that the Amazon Linux used. But now it's asking for the root password, which I have no clue what it is... – hobbes3 Mar 6 '12 at 23:31
@hobbes3 - Like I said, I haven't used Amazon as a provider, so I'm not sure how that process works (did they e-mail you a password? did you set one during setup?). You could either check with Amazon or post another question any maybe someone with some EC2 experience can help you out. – Ek0nomik Mar 7 '12 at 15:09
I was suppose to log in as ec2-user, not as root first. Thanks for the response! – hobbes3 Mar 7 '12 at 16:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.