Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

There is nothing writing to the Apache error log and I can not find any scheduled tasks that may be causing a problem. The restart occurs around the same time, 3 times over the past week at 12:06 am. Then also in the 3-4 am time frame.

I am running Apache version 2.2.9 on Windows 2003 server version.

The same behavior was happening prior to the past week, where there was an error being written to the Apache error log indicating that the MaxRequestsPerChild limit was being reached. I found this article,

suggesting setting MaxRequestsPerChild to 0, which I did and the error stopped reporting to the error log, but the behavior of restarting continued, although not as frequently.

share|improve this question
Can you clarify what you mean by "going down"? If it's not writing to the error log, then it's not restarting. Is it actually writing startup messages to the error log? What error do clients get when attempting to access a page? – Shane Madden Mar 8 '12 at 0:52
That's a good point, we have 3rd party software called WhatsUpPro, that monitors servers in our environment that is reporting that server as going down. Same thing again last night in the wee hrs of the am, so I can't check to see if it actually was down...again, no message written to the Apache error log. – jamesTheProgrammer Mar 8 '12 at 14:00

MaxRequestsPerChild determines how many requests each process will handle before voluntarily expiring.The documentation indicates that setting this to 0 is recommended on Windows because no new process will be spawned if it does expire.

Have you also set MaxThreadsperChild to the recommended value ?

share|improve this answer
I am looking at the apache2.2/conf/extra/httpd-mpm.conf file where I changed the MaxRequestPerChild setting to 0, and see ThreadsPerChild set to 150. Are you suggesting setting this to something else? – jamesTheProgrammer Mar 7 '12 at 15:49
I could not determine from your post if this was already at the value recommended by the documentation you included. If this is not it, examine your error logs closely for possible issues. – adaptr Mar 7 '12 at 16:03
I checked here again and found reference to ThreadsPerChild, it recommends setting of 150, which I have. I am not getting any information reporting in the Apache error log. – jamesTheProgrammer Mar 7 '12 at 16:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.