Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have created this cluster on Amazon's EC2 service. I can connect to the sql instance from the first node (there is only one node in the cluster at this time) using the cluster name, so I know that much works.

I have another server in another Security Group (ports 1433 and 1434 opened between groups) that I am installing the SQL Reporting Services on. During the setup of the RS portion, it asks me to define a database or to create a new one. I want to point this RS instance at my SQL cluster, however I am presented with the error message in the title of this post, the troublesome -40 error.

I know the basics about resolving this (make sure Windows firewall holes are open, TCP/IP is enabled in Configuration Manager) but everything I find about diagnosing (or even configuring remote access) doesn't really address the cluster factor.

In Configuration Manager, TCP/IP is enabled, and listen all is set to yes, but in the tab where individual IPs are listed, none of them are 'enabled'. Should I enable both the node IP AND the cluster IP? Any? None?

I know I'm overlooking something probably very simple, but I'm stuck nonetheless.


share|improve this question
I know also that the security groups are configured properly (if a little loose, for now) and that the DNS for the domain is working because nslookup returns the right ip for the cluster name. Is there something about Amazon and not having one of their interfaces attached to an IP that is causing this? – JohnThePro Mar 7 '12 at 20:34
and adding the cluster name and IP in the host file of the designated RS server did not work either. – JohnThePro Mar 7 '12 at 20:57
Also both 'Network Interfaces' (the one attached to the RS server, and the one attached to the SQL server) have the 'source/dest check' feature disabled. – JohnThePro Mar 7 '12 at 20:58
AND I've also now disabled the Windows firewalls between as well. No change. – JohnThePro Mar 7 '12 at 21:38
up vote 0 down vote accepted

This is a limitation of Amazon VPC at this time. An instance cannot and will not receive traffic for multiple IP addresses.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.