Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have read a couple other threads on here, but I am looking for a reliable solution for backing up a Windows 2008 server to Amazon S3, I would like to sync my file changes to amazon on a daily basis.

I tried a tool called "S3.exe" (http://http://s3.codeplex.com) but that doesn't seem to be working. I tried using the put command but I keep getting a 404 error. I also noticed the last update was in Jun 2010. Its possible Amazon updated their API.

Does anyone have any other recommendations? I tried some other tools that just doesn't seem to work at all and are poor at reporting the actual problem.

  1. Cyberduck
  2. Dragon Disk

Both software installs without an issue but both just doesn't upload the files to S3 and doesn't report what the problem might be. I am able to list my buckets and folders. I even tried running them with Administrator privs.

I would prefer a command line app but a GUI will work also.

Per the comments I have included the command line within my batch file script:

s3 auth KEY SECRET
s3 put BUCKETNAME/backups/Ares.server1.com/ d:\webroot\ /sub /verbose

I have removed the KEY, SECRET and BUCKETNAME for security purposes.

I am getting the error:

s3.exe version 1.7 - check for updates at http://s3.codeplex.com

Using MIME type text/plain backups/Ares.server1.com/!Backups/Websites/Ad/Ad/WWWRO OT/1GSHR6-bSt323SLa6cgsVCTlWPA.txt WebException (The remote server returned an error: (404) Not Found.) with status code 404 The remote server returned an error: (404) Not Found. at System.Net.HttpWebRequest.GetResponse() at com.amazon.s3.Response..ctor(WebRequest request) at com.amazon.s3.AWSAuthConnection.put(String bucket, String key, Stream str, SortedList headers, Int64 startByte, Int64 bytes) at com.amazon.s3.AWSAuthConnection.put(String bucket, String key, Stream str, SortedList headers) at s3.Commands.Put.Execute() at s3.Program.Main(String[] originalArgs)

Also I was able to place a file using Cyberduck (without the sync feature) and that works. So I don't believe its a permission issue. Thank you!

share|improve this question

closed as off-topic by kce, mdpc, EEAA, Dave M, Falcon Momot Feb 13 at 1:53

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions seeking product, service, or learning material recommendations are off-topic because they tend to become obsolete quickly. Instead, describe your situation and the specific problem you're trying to solve." – kce, mdpc, EEAA, Dave M, Falcon Momot
If this question can be reworded to fit the rules in the help center, please edit the question.

    
It might help if you posted the command line you're using and the subsequent error... –  Bart Silverstrim Mar 8 '12 at 13:25
    
Bart, I went ahead and added some more info about my S3.exe command line usage. Thanks. –  gdx Mar 8 '12 at 13:42
    
Any reason for a downvote? –  ekaj Mar 8 '12 at 13:51

1 Answer 1

up vote 2 down vote accepted

S3 AUTH KEY SECRET will not work from batch script. Use S3 PUT with /key: and /secret: options. Works really nice for backups, especially with /sync option.

share|improve this answer
    
I tried using the command: s3 put <BUCKET>/Backups/Ares/ D:\Webroot\MSSQL\MSSQL10_50.MSSQLSERVER\MSSQL\Backup\ /sub:withdelete /yes /verbose /key:KEY /secret:SECRET KEY It performs an upload on a pretty big file (100MB) and then returns an error (see above), 404 error. I don't get why its doing this. If I put in an invalid key I get a different error (Forbidden, which makes sense)! –  gdx Mar 8 '12 at 17:57
    
Can you try with only one file, and without /sub: –  dusan.bajic Mar 9 '12 at 8:15
    
I removed the /sub and specified a particular file, I get the same error (404). By the way I am running version 1.7. What version are you running? –  gdx Mar 9 '12 at 14:19
    
it is 1.7 also. i can't really see where the problem is, i upload more then 2GB daily (files are 100MB on average) without problem. can you try without paths (run s3.exe from same folder where source file is, and upload to bucket root? Here is my bat: "C:\path\to\s3.exe" put bucket-name/qqqq/wwwwww/ "C:\folder\subfolder\*.log" /sync /key:yyyyyyyyyyyy /secret:xxxxxxxxxxxxxx /nogui –  dusan.bajic Mar 10 '12 at 0:43
1  
I was able to figure it out! Apparently my bucket name on Amazon needs to be all lower case. I created a new bucket with all lower case, pointed to it and that seemed to have did the trick! Weird but it works. –  gdx Mar 11 '12 at 15:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.