Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed Squid in my machine running Arch Linux. When I try to start it, it gives me this message :

bash: /usr/sbin/squid: cannot execute binary file

How can I fix this?

share|improve this question
How did you install it? Did you compile from source or use a package appropriate for your system? – Zoredache Mar 9 '12 at 4:55
@Zoredache I just used pacman to install it from the repository – THpubs Mar 9 '12 at 5:02
up vote 1 down vote accepted

Is it possible that you mixed up some repos? Maybe you have a 32 bit Arch and installed the 64 bit Squid package?

share|improve this answer
Nope... I have ARM and installed the ARM package – THpubs Mar 9 '12 at 10:13
Pleas post the output of: uname -a and file /usr/sbin/squid – duenni Mar 9 '12 at 10:27
uname -a : Linux plug-server 3.1.10-4-ARCH #1 PREEMPT Wed Feb 29 04:02:24 UTC 2012 armv5tel Feroceon 88FR131 rev 1 (v5l) Marvell SheevaPlug Reference Board GNU/Linux – THpubs Mar 9 '12 at 10:29
file /usr/sbin/squid : /usr/sbin/squid: data – THpubs Mar 9 '12 at 10:29
Whoops, file /usr/sbin/squid doesn't show what I expect. Hm, don't have access to a linux box by now, can't remember exact command out of my head. Anyway, I see three possibilities here: 1. Package was compiled with wrong architecture 2. You are using the wrong package for your architecture or 3. What are your mount options? Is /usr mounted with noexec switch? – duenni Mar 9 '12 at 10:49

If possible, I would

pacman -Rs squid
pacman -Syu squid

rc.d start squid

and carefully check the logs for both pacman and squid.

share|improve this answer
Did it... The pacman log is fine except for : [2012-03-09 08:54] warning: /etc/squid/squid.conf saved as /etc/squid/squid.conf.pacsave I removed it before re installing Squid. The squid logs are empty (The Squid folder in /var/logs is empty!) – THpubs Mar 9 '12 at 9:36
Try to change mirror editing /etc/pacman.d/mirrorlist uncommenting all but the one line for the mirror you choose and repeat the above steps. – marcoc Mar 9 '12 at 9:54
Tried two mirrors... Cleared pacman cache and tried to re install twice... Still the problem is there! – THpubs Mar 9 '12 at 10:13

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.