Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We are running a Ubuntu 10.04 VM on a Hyper-V system,
The VM is dedicated to running one of our web applications.

We have enabled the Hyper-V drivers in /etc/initramfs-tools/modules like so:

hv_vmbus
hv_storvsc
hv_blkvsc
hv_netvsc

And updated the kernel image like so:

$ update-initramfs -u

And all was good... until..

This morning i got a support request that our web application was throwing an error 500, so i checked the logs and nothing was there.

Then I remembered that I had seen this on another of our ubuntu servers so I...

$ touch foo.txt

And my suspicions were confirmed:

touch:  cannot touch `foo.txt':  Read-only file system

Why is the filesystem randomly becoming readonly?

Is this only in Ubuntu on HV? Is it a problem on RedHat or Cent?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Can you check the log? Most likely the filesystem had errors, and went into read-only state because of it.

(Assuming you're using ext3 or ext4, as are Ubuntu's defaults:) You can adjust this behavior with the errors mount option.

errors=remount-ro is the default; errors=continue (to stay read-write at your own peril) and errors=panic (stop, drop, and roll crash) are your other options.

share|improve this answer
add comment

This is a Hyper-V issue , hosts running Red Hat or Centos will have the same problems

share|improve this answer
2  
On what do you base this conclusion? Supporting documentation would be very helpful. –  voretaq7 Apr 3 '12 at 17:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.