Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently started to manage the existing network of a small business. They have about 10 machines, with various versions of Windows (mostly XP Pro and Seven, 32 bits).

I installed a new server (a headless PC with good hardware, not rack-mounted), for file sharing and backup (this was previously done from a workstation), and used Win 7 Pro x64 as the OS.

I setup the server, shared the folder I wanted, with the following settings:

  • network type: work
  • workgroup: workgroup (same on all PCs of the network)
  • sharing settings: password access on
  • all shared folders are shared with Everyone, with full read/write access both in sharing and security tabs

Everything worked well, I left the office in the evening, but when they came back in the morning, XP machines couldn't access any of the shared folders. The 7 (and Visa) machines were fine though. I tried different things (I could connect to the server from XP machines using remote desktop), but in the end I simply rebooted the server, and it worked.

Same thing happened this morning, access denied from XP machines, server reboot fixed the problem.

I check, nothing happened on the server during the night, except automatic backup from the main disk to a network share.

What could be the problem?

share|improve this question
1  
Disable caching on the share ( net share sharename /cache:None ). If that resolves the issue, SMB2 is the culprit. –  EKW Mar 9 '12 at 13:22
    
Great, thanks a lot for this. I'll try it later today, and will let you know. If indeed this is the problem, should I do something else? Or disabling caching is enough? –  Wookai Mar 9 '12 at 13:45
    
Should be enough if it fixes it. I didn't make it an answer because this is a "WhyTF did that work" (That is to say, it won't break anything, but it shouldn't work, even though it sometimes does) –  EKW Mar 9 '12 at 13:56
    
One of the shares already had caching disabled. I disabled caching on the others. We'll see tomorrow if the problem reappears or not. If it does, what is your next best guess? –  Wookai Mar 9 '12 at 18:21
    
For troubleshooting, I'd try to stick around and see if this starts happening as soon as that backup runs. Could also check the Security log and see what reason it gives for the failure. –  EKW Mar 9 '12 at 20:41
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.