Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

One of my HAProxy monitoring script isn't working on a newly setup HAProxy box. I've tracked down the issue to the output of the stats socket rather than with the script itself.

I'm getting values of "0" being reported via the socket, but the correct values from the webinterface.

Can anyone explain the differences in the output?


From the output of echo 'show stat' | nc -U /var/run/haproxy.socket:

pxname,svname,qcur,qmax,scur,smax,slim,stot,bin,bout,dreq,dresp,ereq,econ,eresp,wretr,wredis,status,weight,act,bck,chkfail,chkdown,lastchg,downtime,qlimit,pid,iid,sid,throttle,lbtot,tracked,type,rate,rate_lim,rate_max,check_status,check_code,check_duration,hrsp_1xx,hrsp_2xx,hrsp_3xx,hrsp_4xx,hrsp_5xx,hrsp_other,hanafail,req_rate,req_rate_max,req_tot,cli_abrt,srv_abrt,
haproxystats,FRONTEND,,,0,0,4096,0,0,0,0,0,0,,,,,OPEN,,,,,,,,,1,1,0,,,,0,0,0,0,,,,0,0,0,0,0,0,,0,0,0,,,
haproxystats,BACKEND,0,0,0,0,4096,0,0,0,0,0,,0,0,0,0,UP,0,0,0,,0,155,0,,1,1,0,,0,,1,0,,0,,,,0,0,0,0,0,0,,,,,0,0,
vip1,FRONTEND,,,0,0,4096,0,0,0,0,0,0,,,,,OPEN,,,,,,,,,1,2,0,,,,0,0,0,0,,,,0,0,0,0,0,0,,0,0,0,,,
webservers,web1,0,0,0,0,,0,0,0,,0,,0,0,0,0,UP,1,1,0,0,0,155,0,,1,3,1,,0,,2,0,,0,L7OK,200,0,0,0,0,0,0,0,0,,,,0,0,
webservers,web2,0,0,0,0,,0,0,0,,0,,0,0,0,0,UP,1,1,0,0,0,155,0,,1,3,2,,0,,2,0,,0,L7OK,200,0,0,0,0,0,0,0,0,,,,0,0,
webservers,web3,0,0,0,0,,0,0,0,,0,,0,0,0,0,UP,1,1,0,0,0,155,0,,1,3,3,,0,,2,0,,0,L7OK,200,0,0,0,0,0,0,0,0,,,,0,0,
webservers,web4,0,0,0,0,,0,0,0,,0,,0,0,0,0,UP,1,1,0,0,0,155,0,,1,3,4,,0,,2,0,,0,L7OK,200,1,0,0,0,0,0,0,0,,,,0,0,
webservers,web5,0,0,0,0,,0,0,0,,0,,0,0,0,0,UP,1,1,0,0,0,155,0,,1,3,5,,0,,2,0,,0,L7OK,200,0,0,0,0,0,0,0,0,,,,0,0,
webservers,web6,0,0,0,0,,0,0,0,,0,,0,0,0,0,UP,1,1,0,0,0,155,0,,1,3,6,,0,,2,0,,0,L7OK,200,0,0,0,0,0,0,0,0,,,,0,0,
webservers,BACKEND,0,0,0,0,0,0,0,0,0,0,,0,0,0,0,UP,6,6,0,,0,155,0,,1,3,0,,0,,1,0,,0,,,,0,0,0,0,0,0,,,,,0,0,

CSV output of webinterface from the same server:

pxname,svname,qcur,qmax,scur,smax,slim,stot,bin,bout,dreq,dresp,ereq,econ,eresp,wretr,wredis,status,weight,act,bck,chkfail,chkdown,lastchg,downtime,qlimit,pid,iid,sid,throttle,lbtot,tracked,type,rate,rate_lim,rate_max,check_status,check_code,check_duration,hrsp_1xx,hrsp_2xx,hrsp_3xx,hrsp_4xx,hrsp_5xx,hrsp_other,hanafail,req_rate,req_rate_max,req_tot,cli_abrt,srv_abrt,
haproxystats,FRONTEND,,,1,2,4096,309,186616,3323540,0,0,0,,,,,OPEN,,,,,,,,,1,1,0,,,,0,1,0,4,,,,0,225,0,0,83,0,,1,4,309,,,
haproxystats,BACKEND,0,0,0,1,4096,83,186616,3323540,0,0,,83,0,0,0,UP,0,0,0,,0,231,0,,1,1,0,,0,,1,1,,2,,,,0,0,0,0,83,0,,,,,0,0,
vip1,FRONTEND,,,6,11,4096,20,45181,1069426,0,0,0,,,,,OPEN,,,,,,,,,1,2,0,,,,0,0,0,7,,,,0,69,3,4,0,0,,0,30,76,,,
webservers,web1,0,0,0,2,,13,7445,243262,,0,,0,0,0,0,UP,1,1,0,0,0,231,0,,1,3,1,,13,,2,0,,5,L7OK,200,1,0,12,1,0,0,0,0,,,,0,0,
webservers,web2,0,0,0,1,,13,7445,127627,,0,,0,0,0,0,UP,1,1,0,0,0,231,0,,1,3,2,,13,,2,0,,5,L7OK,200,0,0,12,0,1,0,0,0,,,,0,0,
webservers,web3,0,0,0,1,,13,7570,81039,,0,,0,0,0,0,UP,1,1,0,0,0,231,0,,1,3,3,,13,,2,0,,5,L7OK,200,0,0,13,0,0,0,0,0,,,,0,0,
webservers,web4,0,0,0,1,,13,8053,182209,,0,,0,0,0,0,UP,1,1,0,0,0,231,0,,1,3,4,,13,,2,0,,5,L7OK,200,1,0,11,1,1,0,0,0,,,,0,0,
webservers,web5,0,0,0,2,,12,7288,230933,,0,,0,0,0,0,UP,1,1,0,0,0,231,0,,1,3,5,,12,,2,0,,5,L7OK,200,1,0,11,0,1,0,0,0,,,,0,0,
webservers,web6,0,0,0,1,,12,7380,204356,,0,,0,0,0,0,UP,1,1,0,0,0,231,0,,1,3,6,,12,,2,0,,5,L7OK,200,1,0,10,1,1,0,0,0,,,,0,0,
webservers,BACKEND,0,0,0,6,0,76,45181,1069426,0,0,,0,0,0,0,UP,6,6,0,,0,231,0,,1,3,0,,76,,1,0,,30,,,,0,69,3,4,0,0,,,,,0,0,

Version information:

[root@haproxy ~]# haproxy -v
HA-Proxy version 1.4.19 2012/01/07

Relevant config exert:

global
    log         127.0.0.1 local0 debug
    maxconn     4000
    user        haproxy
    group       haproxy
    daemon
    stats socket /var/run/haproxy.socket

Permissions:

[root@haproxy ~]# ls -lah /var/run/haproxy.socket
srwxr-xr-x 1 root root 0 Mar  9 14:13 /var/run/haproxy.socket
share|improve this question
    
Could be a bug. Have you reported this to HAProxy's author? –  sendmoreinfo Oct 27 '12 at 8:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.