Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a peer to peer network set up with a linux web server as a test environment, and a NetGear WNR854T is set up as a wireless gateway and router. However, from time to time I am unable to resolve the name of the linux server. This happens regularly from one of our Vista computers connecting through the wireless gateway, although it almost never occurs with one of the wired Vista computers. I have not seen the problem occur when looking up the names of windows boxes, although it may still be occurring with them as well. Also, we have a mac, and it usually can connect if .local is appended to the name, but not always.

The router is set up with a pretty basic setup - i.e. acting as a DHCP server, forwarding DNS requests to our internet providers DNS servers. The linux server has an address reservation on the router. What other settings can I look into in order to resolve this? I'd rather not modify local hosts files if possible.

share|improve this question

2 Answers 2

You need an internal DNS server and you need to create the appropriate zones for your internal DNS namespace (domain name). The router has no capability to create DNS zones and your ISP knows nothing about your internal DNS domain name. Once you've set up an internal DNS server, configure it to use the router as a forwarder and configure all of your internal clients to use the new DNS server for DNS.

share|improve this answer

How are you expecting the machines to be able to look up *.local addresses? Does the router do dns caching of some sort? Certainly your ISP doesn't have your *.local addresses. If you want to debug your DNS issues, it helps to figure out how it's supposed to be working, first.

share|improve this answer
    
To be honest, I'm not entirely sure. Networking is not one of my fortes. The Netgear router has some sort of DNS capabilities, though, because it does manage to route the host names properly part of the time. –  jobu1324 Jul 7 '09 at 6:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.