Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can't use yum because port 80,443 are being blocked by a firewall.

I setup a ssh proxy tunnel (socks v5), it works fine.

I've tried to find how to use yum with a socks v5, but looks like it only can be done with a http proxy.

how can I use yum with a socks v5 proxy? I can't use http proxy.

EDIT: additional information

I can't use yum at all. distros: fedora 16 and ubuntu, neither of these two have a compiler.

share|improve this question

Have you tried ProxyChains?

share|improve this answer
I don't have installed proxychains. And I can't install it from source because I don't have a c compilter – jonv1 Mar 9 '12 at 18:11

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.