Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have several errors in my log. My environment is:

  • Server 2008 R2 (virtual machines on Server Core stack).
  • AppAssure Replay 4 as the backup solution.
  • In the evening backup goes okay usually, snapshots get created fine.
  • During the day and other times, it's a different story: Snapshots fail: numerous writers get into a failed state, a timeout.
  • AppAssure's response at one point in time was to restart the Agent service. That solved the problem for a short time, but when I tried it today, that didn't work at all.

I've tried to look high and low for a way to just reset the writers - I thought they were controlled by the VSS Service/Microsoft Shadow Copy Provider, but apparently not. Should I have the Hyper-V Shadow Copy Provider running, over the Microsoft Shadow Copy Provider?

My errors, explicitly:

  • Unable to take VSS snapshot and transfer data for 'C: ...'Error taking VSS Snapshot of volume(s): AsyncWait for DoSnapShotSet failed - Snapshot vetoed by provider.

  • Event ID: 12289, VSS. 'Volume Shadow Copy Service error: unexpected DeviceIOControl (\?\Volume{guid} hr=9x80070057, The parameter is incorrect. Operation: Automatically choosing a different volume. Professing EndPrepareSnapshots Context: Execution, System Provider

  • Event ID: 22, volsnap: The shadow copy storage volume specified for shadow copies on volume C: could not be added.

  • A generic error when I try to view the 'Shadow Copies' tab on my C: drive.

  • Running 'DiskShadow list writers status' gives me the status code 7, and what it means specifically: 'VSS_WS_FAILED_AT_PREPARE_BACKUP'.

I believe, obviously that all these errors are related. Most solutions I see say to stop the VSS and related services, unregister some modules, and register them again as a way of resetting the writers (for Server 2003). I disagree with this solution, there is no reason why I shouldn't be able to solve this without needing to reboot the box; especially in Server 2008.

Any and all help would be greatly appreciated, or at the very least letting me know that I'm perhaps overloading I/O, and to space out my snapshots (they are taken every hour on this server with errors: it's a file-server)

share|improve this question

1 Answer 1

I had a similar problem. Check out this app I don't remember where it was I think in the support page there was an entire list of ways to fix VSS errors. I ended up re-registering dlls. I don't think a reboot was needed

share|improve this answer
    
I ended up fixing this issue by moving my backups to a different server with less I/O. It's not perfect, but at least I get much more consistent backups. –  DarkSim905 Jun 27 '12 at 16:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.