Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I own two Sunfire v100 servers, and I use hyperterminal to connect to them.

I am trying to re-install Solaris on one of them, so I put in the LOM cable and unplugged the harddrives.

Here's the current console text:

LOMlite starting up.

CPU type: H8/3437S, mode 3
Ram-test: 2048 bytes OK
Initialising i2c bus: failed (0xfe held busy)
OK
Searching for EEPROMs: none
Will use eeprom address 50
I2c eeprom @50: failed
i2c bus speed code 00... OK
Probing for lm80s: none
Probing for lm75s: none
System functions: PSUs fans breakers gpio temps host CLI ebus clock
Unexpected reset

LOMlite console
lom>

I am trying to get to the OK prompt, through lom> console except it says this:

Console is not shared

I've tried resetting this:

lom> bootmode reset_nvram

That does nothing, I'm still not able to get into OK for OpenBoot.

Also tried:

lom> bootmode forth

I will be installing Solaris 11 Text-Version from a CD-ROM in the drive.

share|improve this question
    
have you considered contacting Oracle support? You've already paid for it. –  goo Mar 9 '12 at 22:49
    
Is that CPU even still supported by Solaris 11? I've heard an Oracle Sales guy speaking about Support for USII/III/IV being dropped in Solaris 11. Wish you good luck in getting it to run, though! –  juwi Mar 10 '12 at 0:00
    
@goo - This thing is from 2003, it's a piece of junk, and I might just sell it on eBay or something. –  ionFish Mar 10 '12 at 1:43
    
@juwi - I will try Solaris 10, but I'm not even able to get to the boot menu because the system itself isn't going to the OK> terminal, 'console' fails to open for some reason. –  ionFish Mar 10 '12 at 1:43

3 Answers 3

You're missing the SCC, or it's damaged.

You cannot boot a server with a missing / damaged SCC.

Tell-tale sign;

Searching for EEPROMs: none

It should say something like;

Searching for EEPROMs: 50(cfg)

Check the back of the v100. There's a big purple credit-card reader thing, called a "System Configuration Card Reader"

Is there a white card zip-tied into it? No? That's the EEPROM (Electrically Erasable Programmable Read-Only Memory)

Search eBay for "system configuration card". Don't pay more than $20 USD for it. Shouldn't matter what kind of system it's from. All SCCs were the same form factor and size (to my knowledge).

Side-Note: You will not be able to install Solaris 11 on there. Support for that CPU has been discontinued. (All 32-bit support was chopped in Solaris 11, along with the older SPARC64 systems).

If you want to run Solaris 11 on a SPARC, your best bet MIGHT be a T-1000 or T-2000 (haven't tried it, personally). Stick with Solaris 10 for SPARC.

Solaris 11 x86 runs decent on most newer 64-bit x86 CPUs (I use Virutalbox on a AMD Phantom)

share|improve this answer

This article suggests to get to the ok prompt from lom

lom> break
ok>

although this article suggests

lom> boot forth
lom> poweron

will get you to

ok>

from which you can

ok> boot cdrom
share|improve this answer
    
Doing the first method pops Console is not shared which is my problem. The second thing brings this: lom>boot forth lom>poweron lom> –  ionFish Mar 9 '12 at 21:47
    
does anything here sunshack.org/data/sh/2.1.8/infoserver.central/data/syshbk/… work ? –  Iain Mar 9 '12 at 21:50
    
Option 1 is not possible, there is not a functional copy of Solaris. Option 2 failed, was in my original post. Option 3: after resetting, the thing boots up with orange failure light. It did boot up after resetting four times, System functions: PSUs fans breakers rails gpio temps host CLI ebus clock. Unexpected reset Still not working. –  ionFish Mar 9 '12 at 22:01

Can you give me an

environment

and a

show eventlog

from lom, because that output doesn't look very good (come on, it didn't find an EEPROM and I2C failed). If theres anything interesting in

lom -a

that might be of interest, too.

share|improve this answer
    
fixee.org/paste/45kjmr7 that's basically all of the info I have here, not much else for me to do with the server at the moment. It's mounted in a cabinet with the LOM cable going to a laptop, and a network cable on port 0 going to a switch with the other servers. show eventlog will not show anything else because the server was just reset. –  ionFish Mar 10 '12 at 2:07
    
Mmh... tried a reset_nvram followed by reset, yet? –  juwi Mar 10 '12 at 2:12
    
Yes sir. lom>reset lom>console Console is not shared lom>bootmode reset_nvram lom>reset lom>bootmode reset_nvram lom>poweroff lom>poweron lom> –  ionFish Mar 10 '12 at 2:14
    
Got one more: bootmode -u; reset; let it powercycle; do the jumper –  juwi Mar 10 '12 at 2:16
    
Results: fixee.org/paste/mquxaoh –  ionFish Mar 10 '12 at 2:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.